RAK7249 DIY Gateway use WIFI as WAN

(Simon R.) #1

This post was flagged by the community and is temporarily hidden.

0 Likes

(Steven Tang) #2

HI , Simon
Can you paste some picture for the web setting page on the firmware and wifi connection ?

0 Likes

(yutao) #3

When Wi-Fi works in station mode, it belongs to zone wan by default. You do not need to change the configuration of the firewall.

I guess the problem is with the Wi-Fi antenna connection. If you only have one Wi-Fi antenna, you should connect it to the connector marked in the picture.

0 Likes

(Simon R.) #4

This post was flagged by the community and is temporarily hidden.

0 Likes

(Simon R.) #5

Thank you for your reply,

i reset the Gateway to get standard firewall settings again.
I also connected various antennas to the point you marked, but it is allways 0%.
What is strange, is that it connects to the wifi and i can send and receive pings through it. After deleting the standard wan route through ssh.

0 Likes

(Steven Tang) #6

HI , Simon
please ignore the signal quality . it is only a icon now . it cannot sync the data now .

acturlly , you have conncted to the router . and please show me the firewall config.

0 Likes

(Simon R.) #7

This post was flagged by the community and is temporarily hidden.

0 Likes

(Steven Tang) #8

HI , Simon
sorry , i mean the firewall webpage .

I have test in my side for the connection . you’d better check the antenna info following @yutao suggestion .https://forum.rakwireless.com/uploads/default/original/1X/09da17ca733cbb75bfb07d2a30e4834fa95171e9.jpeg

0 Likes

(Simon R.) #9

Hi Steven

cat /etc/config/firewall

config defaults
option syn_flood ‘1’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘REJECT’

config zone
option name ‘lan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘REJECT’
option network ‘lan’

config zone
option name ‘wan’
option input ‘REJECT’
option output ‘ACCEPT’
option forward ‘REJECT’
option masq ‘1’
option mtu_fix ‘1’
option network ‘wan wan0 wwan’

config rule
option name ‘Allow-http’
option src ‘wan’
option proto ‘tcp’
option dest_port ‘80’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-https’
option src ‘wan’
option proto ‘tcp’
option dest_port ‘443’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-ssh’
option src ‘wan’
option proto ‘tcp’
option dest_port ‘22’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-DHCP-Renew’
option src ‘wan’
option proto ‘udp’
option dest_port ‘68’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-Ping’
option src ‘wan’
option proto ‘icmp’
option icmp_type ‘echo-request’
option family ‘ipv4’
option target ‘ACCEPT’

config rule
option name ‘Allow-IGMP’
option src ‘wan’
option proto ‘igmp’
option family ‘ipv4’
option target ‘ACCEPT’

config include
option path ‘/etc/firewall.user’

config rule
option src ‘wan’
option dest ‘lan’
option proto ‘esp’
option target ‘ACCEPT’

config rule
option src ‘wan’
option dest ‘lan’
option dest_port ‘500’
option proto ‘udp’
option target ‘ACCEPT’

config forwarding
option dest ‘wan’
option src ‘lan’

config rule
option enabled ‘1’
option target ‘ACCEPT’
option name ‘all’
option src ‘
option dest '

i already connected the Antenna to the port recommended by yutao. I can sucsessfully connect to TTN now through wifi :slight_smile: . Still it is 0% but that is no problem since it is working. Thank you a lot for your help.

0 Likes

(Steven Tang) #10

HI , Simon
thanks for your info . and we will update the signal issues asap . thanks again .

0 Likes