Arduino Not compiling stuck in compiling -But no errors?

I downloaded the Boards of the RAK4631 RUI nRF. When i want to compile any program it gets stuck in compiling and never finish. No error appears.
But if i compile it on a arduino uno board it compiles just fine

Welcome to the forum @Hein

Could be an incomplete installation of the BSP. Try to remove it and reinstall.

Thanks
I have removed and reinstalled it about 10 times thinking it will start working but nothing is happening. Still just gets stuck in compiling

The normal nRF without RUI works but with RUI It doesnt

What source code do you try to compile?

I saw you sent the same question to our customer support desk. As there and here are the same people, I will answer you here only.

What if you compile an “empty” code?

#include <Arduino.h>

void setup()
{
}

void loop()
{
}

This is what i tried to compile still did not work.

Arduino IDE 1.x or 2.x ?
Windows, Linux or MacOS?
Any virus scanner installed?

Before reinstalling close Arduino IDE.
Then delete the folders
staging, cache, packages/rak_rui
and the file
package_rakwireless_com_rui_index.json
from your Arduino15 folder.

Then try to reinstall.

If that doesn’t help, then I don’t know what’s wrong. It is working fine for others and myself.

I tried both IDEs on windows
Kaspersky antivirus.
I will try it out thanks for the suggestions.