Arduino on RAK4600

I’ve designed a custom board with RAK4600 where I’d like to use Arduino.
I’ve followed the step-by-step guide on github, uploaded the feather bootloader using daplink/jlink successfully, using the pyocd command.

I can see the device is in DFU mode, because with my nRF Connect app, I can discover “AdaDFU”.
However, when I try to flash the arduino user code, I get the following:

Upgrading target on COM5 with DFU package C:\Users\S�k�sd Attila\AppData\Local\Temp\arduino\sketches\55EEC7B9B2BAABF73E8F39117CEAD061\ Flow control is disabled, Single bank, Touch disabled
Opened serial port COM5
Starting DFU upgrade of type 4, SoftDevice size: 0, bootloader size: 0, application size: 75544
Sending DFU start packet
Timed out waiting for acknowledgement from device.
Sending DFU init packet```

I've confirmed that my UART works using the AT firmware. Also tried shorting P0.18/19 and holding nRST too.

Please help!

Hi Attila,

I don’t have any RAK4600 with Arduino bootloader to test, but the instructions say to connect P0.18 (== Pin 10) to GND, not to P0.19

Hi @attilasukosd ,

I tested the guide on my RAK4600 Evaluation Board and it is still working. I upload BLE UART and it works fine and can connect to my android phone.

Please check @beegee suggestion, if you do not short RX1 to GND, you will not be able to upload.

Thanks for the replies! I’ve tried shorting P0.18 to GND and release on reboot, but serial DFU still doesn’t work.

I can see “AdaDFU” in my nRF Connect app. Does that mean that the device is in DFU mode? or is that always visible?

Is there a way to upload my Arduino app through the nRF app on iOS?

And last question :slight_smile:

Is it possible to recompile the arduino bootloader? I would like to try to debug why it doesn’t work, maybe I can augment the code with sme debugging to understand where it goes wrong.

The bootloader is the one from Adafruit for the nRF52832. I am not sure if we did any changes to it. The RAK4600 is EOL since quite some time and nobody is working on it anymore.

Thanks for the reply. It’s a shame that it wasn’t clear for me that the product is EOL when ordering 10 on the webshop :frowning:

Is there a pin compatible alternative with similar functionality?

No, there is no pin compatible device.

The closest from functionality is our RAK4630 or the RAK11720

For the RAK4630 and RAK11720 we offer our RUI3 BSP and API
For the RAK4630, you can as well use the Arduino BSP after changing the bootloader.