AT Command not accepted


I changed baudrate to 4800bps.Then I tried changing the baudrate but failed.

Only ‘at+version’ is success.Everything else fails.

What should I do?

Thank you.

Hi, please share your firmware version.


TX -> RX
RX -> TX

I have the same problem, trying to put the arduino stack, AT commands did not work again, delete the flash with the stm cube programmer, try to install the RUI_RAK811_V3.0.0.13.T2.H_Release.bin version but it doesn’t work either.
since it cannot answer AT command, I cannot put it in BOOT using the SERIAL PORT TOOL, therefore I cannot upgrade the version, I appreciate your help.

Hi @SnarkTail,

You shouldn’t use baudrate 4800 for it.
Please use 115200 and try again.

Hi @ivancho,

Do you mean that you have delete all data on flash by using STMCubeProgrammer?
If it is, that means that the bootloader has been deleted too.
In this case, you should flash the bootloader for your RAK811 firstly, then upgrade the firmware.

He, @velev

Firmware version is

Look at the second line of the image in the first post.

Thank you.

He, @Fomi

Unfortunately, it failed

Thank you.

He, @Fomi

Where is the RAK811 bootloader?

I can’t find RUI_RAK811_BOOT.bin in

Thank you.

Hi @SnarkTail,

Please wait a moment and we’ll update the bootloader file in that folder, or you tell me your email, and i’ll send the bootloader file to you.

1 Like

Hi all,

We’ve just updated the bootloader file on RAK website:

You can download it, and you can download the latest firmware here:

1 Like

Hi, @Fomi,

I successed update bootloader and firmware.

Then AT Command accepted.

Thank you!

Hi, all

Same problem happened with V3.0.0.13.T3.

After using ‘at+set_config=device:uart_mode:1:38400’ to set 38400, using ‘at+set_config=device:uart_mode:1:115200’ does not return to 115200.

Using STM32 Cube Programer, erase full chip flash memroy, load bootloader, load firmware.But the problem was not solved.

Please help me!

Hi @SnarkTail

This is not an instruction to set the baud rate,maybe you have enter to unvarnished transmit mode.If that,you must send “+++”(no “\r\n”) with AT serial to end unvarnished transmit mode.
If not,can you see the initial log of the print when you restart the module now? Modify the baud rate of the serial port to find the current baud rate.Then use “at+set_config=device:uart:1:38400” AT command to set baud rate that you want.

Hi, @leopold

Thank you so much!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.