Boot hang using published RAK2287 software

Issue: Attempt to boot using RAK2287 firmware image at https://downloads.rakwireless.com/LoRa/RAK2287-Mini-PCIe/Firmware/RAK2287_Latest_Firmware.zip fails.
Raspberry PI v3 boots through starting TTN gateway and ChirpStack software, then loops displaying:
while as 001
while as 001
[ OK ] Stopped The Things Network Gateway
[ OK ] Started The Things Network Gateway
while as 001
while as 001

Pi never reaches login prompt and does not turn on sshd, so it is not possible to log in.

Setup: Raspberry Pi v3, 16 GB SD card imaged using Balena Etcher with firmware from https://downloads.rakwireless.com/LoRa/RAK2287-Mini-PCIe/Firmware/RAK2287_Latest_Firmware.zip, RAK22877 LoRa Concentrator Module Pi Hat. (Note that behaviour occurs even if PI Hat is removed)

Server:

Details: This hardware configuration has been successfully booted using the latest Raspbian Buster and Chirpstack Gateway OS (Introduction - ChirpStack open-source LoRaWAN<sup>®</sup> Network Server), but of course the concentrator does not work because this install does not have a configuration for RAK2287 Pi Hat.
I have tried several times to reimage a different SD card and reinstall, but have the same result each time.
Has anyone else experienced this?

Hei @swagner0 ,

Can I suggest you do it manually by installing a fresh Raspberry Pi OS and installing from this repo:

There are instructions for each model.

Regards
Vladislav

Hello @Hobo Vladislav,
Thank you for this suggestion. I will have to try it tomorrow: it’s late evening in my slice of the world and, as much as I would like to try it, I’m not up to a 10 km bike ride to my lab in the dark! :slightly_smiling_face: :biking_man: :crescent_moon:

I think, from examining the choose_model.sh script, that the appropriate selection is

7.RAK7248 no LTE (RAK2287 SPI + raspberry pi)

Do you agree?

@swagner0 ,

Ahaha cool I am in the same boat 10-sih km bike ride from the office to where there is a bed for men. Very early morning here so also dark.
Ad for the firmware you are correct. What you want to choose is 7, if you have the RAK2287 SPI.

Regards
Vladislav