Can i connect rak lorwan industrial gateway with any other brand node!

  1. Can i connect rak lorawan gateway with with any other brand end device!!
    2.I already have other brand gateway in the user manual they mentioned like 10km range ut when i tested in line of sight i got only 600meter range. now i want to switch rak lorawan gateway but i cant blindly purchase seeing manual please any one share the range testing report for WisGate Edge Prime RAK7240 and
    WisGate Edge MaxRAK7249 it helps me lot

thanks in advance

Hi Avian,

  • Yes the brand of the device doesn’t matter. The gateway is just a transmitter. So yes, you can connect nodes from other brands and connect them to the RAK gateway if you need to.
  • Well I don’t know which brand are you talking about, but a 600-meter line of sight range is too low. Maybe there is a problem with the settings or the setup of the gateway/ node that you tested with. You need to check the connection of the cables and the antennas to the gateway.
  • You can find a coverage drive test report for WisGate Edge Max here.

Well thank u @Nikola for the quick reply. but i tried to connect with rak811 breakout board with dragino lg02 gateway but i didn’t receive any payload in ttn network server. can anyone help me out.!!

if i purchase rak gateway is it supports LMIC library!!

Hei @,

It works like this:
LMIC being a library it adheres to the LoRaWAN specs within some degree. RAK gateways are also adhering to the LoRaWAN specs, as such they should work together.
Theoretically is is only a matter of properly setting up the firmware.
You issue is probably due to some mismatch in the configuration of one or both.


The lg02 is not a LoRaWan gateway, and lacks key capabilities needed to be configured to match the normal operation of LoRaWan nodes like a RAK811.

In contrast an actual LoRaWan gateway such as the Wisgate or developer series (or something comparable from someone else) would be, if it were also for the correct frequency band for your region, and if the settings are correctly configured on both that and your node.