Cannot find SSID Rakwireless_XXXX

Issue: Cannot find SSID Rakwireless_XXXX on Windows PC

Setup: RAK2245 pi HAT + Raspberry pi 4

Server:

Details: Following RAK2245 Pi HAT WisLink LPWAN Concentrator Datasheet | RAKwireless Documentation Center document to set up. Downloaded the latest firmware on SD card. Connected both Lora and GPS antennas. After power up, Rakwireless_XXXX SSID is not found.

Hello @pckumar and welcome to the forum,

When you downloaded the firmware, did you flashed it on the SD card (with Balena for example) as shown here?

Yes I used Balena Etcher to flash the image on SD card.

Hmm, the firmware might have failed or got corrupted while flashing. Try to re-flash it and try again. It takes up to 5 minutes for the firmware to start.

Also, when you power the Pi, does the power led on the RAK2245 lights up?

I tried re-flashing the firmware multiple times and still don’t see the SSID. I used both Windows and MacOS to download the image and flash using Etcher.
The Power LED on the RAK2245 lights up. The power led(red) on Raspberry pi 4 lights up and is ON. The ACT led(green) on the pi blinks continuously and then is OFF. After a few seconds it lights up again and blinks continuously and comes to halt. This repeats.

The Raspberry pi 4 (model B with 2GB RAM) is new out-of-box device. Is there any initial configurations to be done before booting the firmware from SD card?

The behavior of the Pi and the HAT seems normal. Can you try to connect a monitor to the Pi and check if it’s booting properly?

I connected to a monitor and the following is the boot log:

start4.elf: is not compatible
This board requires newer software

Please see attached image for full boot log.

The software I flashed is from: https://docs.rakwireless.com/Knowledge-Hub/Learn/WisGate-Developer-Gateway-Firmware-Burning/
Model: RAK2245 Pi HAT WisLink LPWAN Concentrator Version: 4.2.6_20210108
But once extracted, the final image is : RAK7243_on_Raspbian_OS_V4.2.5_20200909.img
Why is there a difference in the version number in the final image? Is this the latest version of software?
Thanks.

Hello @pckumar,

I’ve read that there might be changes in the hardware (as you are stating that the RPi is a fresh new), which may resolve in changes in the software too. Try to download a Raspberry Pi OS from here. And then install rak_common_for_gateway. The installation process is explained in the git repo.

Hi @Martin. Thanks for your help.
I installed Raspberry Pi Lite and then followed instructions in github to download and install rak_common_for_gateway.
I was able to install the software for RAK2245 and login into the device.
I did sudo gateway-config to make changes. However in ThingstoNetwork I do not see my gateway connected.
How do I set the “I’m using the legacy packet forwarder” checkbox and the router options?
What could be the reason my gateway is not connected? Are there changes to be done in gateway-config?
Thanks,
Prasanthi

Hello @pckumar,

First of all, did you configured your gateway to connect to the Internet as shown here. You can easily check if you have Internet access on your gateway by trying to ping any address (e.g ping 8.8.8.8)

Basically, in the sudo gateway-config when you select Setup RAK Gateway Channel PlanServer is TTN you configure the packet forwarder to TTN (I assume you are referring to The Things Network). After doing these changes, the packet forwarder restarts itself. But doing a reboot on the gateway won’t hurt (sudo reboot).

Hi @Martin,
I have connected the Pi through ethernet and am able to connect to the internet. Please refer to the image.
However, when I do a sudo gateway-config I do not see the option to Configure LAN. Please advise.

Hi @Martin, I have tried connecting the Pi to network through Wifi and tested as well. I am able to ping 8.8.8.8 and check the connection. But, the device status in Things Network is still disconnected. Could you please let me know why I am not able to see the device activity in Things Network?

Hello @pckumar,

Firstly, did you configured you gateway to connect to TTN from the UI:

If yes, you can check the daemon.log located at /etc/log/ for debugging. If the concentrator is not starting, check if the SPI interface is enabled in the sudo raspi-config command:

After making any changes, remember to reboot the device.

Hi @Martin
I was able to get the device connected to Things Network. I had to enable SPI and I2C in sudo raspi-config.
I am trying to port the Lora gateway to a custom board (not the raspberry pi). Could you please provide specifics of SPI (mode, clock frequency etc.), I2C and other interfaces to configure in the Linux device tree. The device I am using is Dynamic Dev Tool Page | Microchip Technology
Thanks for your support.

Hi @Martin, any information would be helpful in porting the RAK pi HAT to the custom board. So could you please provide specifics on interfacing? Thanks in advance

Hello @pckumar,

The information about the pins of RAK2245 can be found in the docs center here.
And here is the SX1301_hal repo.

1 Like

i have the same setup, i’m looking a few months for a firmware but notting works.
where can i found the right firmware?

Which of the two setups mentioned in this thread would that be, the new pi4, or the Microchip SAMD board?

Note the thread already provided information on how to install the gateway software on top of an existing operating system for a board, so if nothing else you should be able to follow that.