Cannot upgrade RAK811 firmware/bootloader

Issue: Adapted datarate may not working so i decide to try another firmware.

Setup: Rak811 with CP2102 usb UART. RAK811 Version:3.0.0.14.H.beta2. RUI 3.05. AS923

Server: nothing

Details: When using LoraButton upgrade tool, only Enter BOOT mode success command appear and nothing happen after. When using stm32cubeprogrammer, the chip can be found over uart but cannot do anything include read/wirte. (when trying it said Chip is under protected mode).
Please help me to check adr at this firmware version, i tested Wisnode rak811 at 3.0.0.13 and it work perfectly!

very sorry!
The bootloader of V3.0.0.14.H.bete2 and V3.0.0.13 are different.
I can send you e-mail if you need .
Please leave you e-mail. :smile: :smile: :smile:

you can using: [email protected]
please also send me a change log. In any time, i don’t see this firmware try to rejoin/resend packet. May be it is a bug?

I did this exact same thing, I tried downgrading from V3.0.0.14.H.beta2 to V3.0.0.13. The device does not respond to any AT commands anymore.

I think I need to fully reflash bootloader and firmware, if Nicholas is still monitoring can I get information on how to do this? I’ve worked with STM32 MCU’s in the past so am familiar with their programming tools.

Sometimes, I haven’t figured the pattern/details, you need to issue an

AT+RUN

using the serial tool to get it out of boot loader mode and back in the firmware.

No response, it definitely needs a full re-flash. I am using the “RAK811 LPWAN Evaluation Board” (arduino shield format). The “LoRaButton Upgrade Tool V1.0” times out with “Time out error, Please click STOP to restart operation” when trying to update firmware. both with on-board header in the boot position (pulled up) and normal position (pulled down). The STM32CubeProgrammer can read the contents of flash but not successfully flash.

The CubeProgrammer gives the error "Operation exceeds memory limits when I try to use it to flash the firmware RAK811_HF_V3.0.0.13.T3.bin

I do notice that the chip is identified as an STM32L100x6xxA with 128kB flash but the firmware file size is 131,104 bytes where the chip has 131,072 bytes of flash so this makes sense that it doesn’t fit.

Ok some progress:

  • I found the bootloader for RAK811 HERE
  • I followed these instructions from TTN to flash the bootloader using the STM32CubeProgrammer
  • I tried using the RAK SERIAL PORT TOOL to send at+set_config=device:boot bit it replied “AT cmd error” the RAK did atleast respond with something
  • I continued trying to flash the firmware by following the next step in the instructions from TTN and the firmware loaded successfully.

I then power cycled and tested and it responds to AT commands now and looks like its on firmware V3.0.0.13 as desired:

>>at+version
ž=ï»+OK V3.0.0.13.H.T3
>>at+get_config=device:status
OK Board Core:RAK811
MCU:STM32L151CB_A
LoRa chip:SX1276

seems to be resolved.

Yup, that is my experience. After what is a relatively simple process of flashing the boot loader, the device is dumb until you download the firmware.

None the less, if you put it in boot loader mode to download new firmware, the AT+RUN will return it to it’s current firmware if you change your mind before you download new firmware.

Can you share me bootloader for V3.0.0.14 and V3.0.0.7 firmware?
my mail id is [email protected]

Bootloader is already included on V3.0.0.14, so when you upload it via STM32cubeprogrammer, your bootloader will be updated as well if you are using V3.0.0.13 and below fw versions previously.

I download V3.0.0.14.bin firmware using stm32cubeprogrammer. but it it not doing anything on restart. But, when i download V3.0.0.14.hex file it works but it is not showing device eui. here i attached log of hex file. Why .bin file is not working?

It is great to hear your RAK811 is now working.

To answer your question, .bin file will not work because it doesn’t contain the bootloader code. Only the hex file.

Regaring device eui, you should be able to set the EUIs and keys using RAK811 AT Commands - https://docs.rakwireless.com/Product-Categories/WisDuo/RAK811-Module/AT-Command-Manual/

My RAK811 is working with .hex file of V3.0.0.14 firmware.
Now I want to customized code. so, I want to use rui online compile. I downloaded code from following link.

My code is compiled successfully but its behavior is same. It is not printing anything on reset. RUI compiler gives .bin and .elf output file. And .bin file is not working without bootloader.

Now can you tell me what to do?

@Kajal can you share your zip?

1 Like

Rak811 Module UART1 and UART3 both in RUI_UART_USER mode. How to exit from it and back to normal mode. As, in this mode I am unable to download file from RAK DFU tool. I attach screenshot here