Can't get my RAK5010 to talk to me

I’ve just received my RAK5010, and I cannot get it to talk with me.
I’ve connected the USB port (which comes up as COM77), and opened it in Putty. No matter what character I type, I immediately get
“Invalid at command.
ERROR
RET_CODE:80”

It can’t be an invalid AT command because I can’t get pass press the “a” key.
I’ve tried connecting a USB <-> Serial dongle to the GND, IO3, and IO4 pins. I get no output at all. I’ve tried swapping IO3 and IO4, still nothing. I’ve tried both with and without the connection to the VRef pin.

Any suggestions?

I’ve tried the RAK Serial Port tool, and after I try to send a first command, it hangs.

Hi,
5010 need DTR, so you can try this serial tool:

Unfornately, that doesn’t work either:

Hi,
First, maybe you can refer to this:

  1. Is the module power up normally?
    Blue led on and red blink. If just supply with usb, it maybe restart often. Better add a chargeable battery.

  2. Connect USB port like below. Check your set of the tool.

  3. About at command.
    at+version //check firmware version.
    at+set_config=cellular:(ATI) //check bg96 firmware version
    more details is below:
    https://doc.rakwireless.com/rak5010-wistrio-nb-iot-tracker/at-commands-for-rak5010

Notes:
You should copy the serial tool exe and ini(config file) both to your pc. The ini stores the right config.

Power is from USB.
The blue LED is solid, the red LED is blinking.

I’ve connected an FDDI serial cable to the IO pins on a second module, and I do get the banner when I press the reset button. Version is 3.0.0.7
Nothing that I type into the terminal window gets any response. I’ve tried with putty, SSCOM, and RAK_SERIAL_PORT_TOOL.

Under the device manager, I get “USB Serial Device (COM88)”. I’ve tried opening it with Putty, SSCOM, and RAK_SERIAL_PORT_TOOL. If I send “AT+VERSION”, I get the message “Invalid at command”.

This happens with both modules, so I don’t think this is a HW problem.
(As an aside, I can get an RAK2011 module working, so I must be doing something right.)

And I have copied the .ini file over.

Oh, and I have tried the nRF Connect program, and it doesn’t find the board.

Do you have TeamViewer? I can help long range. Send user and code to my mailbox
[email protected]

Nero,
thanks for the help in getting it working. “Putty” doesn’t work at all, and it seems to put the module into a very weird state. As we also saw, trying to use more than one of the interfaces confuses the module as well. Sometimes, cycling DTR seems to fix it.

Hello,
I have a similar issue with Rak5010:
I’ve flashed the RAK5010_V3.0.0.8.hex firmware and then I’ve connected the USB port to send commands.
I’ve tried to send command listed here:
https://doc.rakwireless.com/rak5010-wistrio-nb-iot-tracker/at-commands-for-rak5010

All the commands response is “Invalid at command” except for two:
at+version
Firmware Version: RUI v3.0.0.8
OK

at+scan=cellular
AT+COPS=?+COPS: (2,“VERY”,“VERY”,“22288”,0),(3,“I TIM”,“TIM”,“22201”,0),(3,“vodafone IT”,“voda IT”,“22210”,0),(0,1,2,3,4),(0,1,2)
OK

Please, could you help me to understand?
Thank you

Hi. Did you use Termite terminal with suggested settings? Did you power the board from the battery connector?

Hi, thank you for your reply.
I’m using a mac and I’ve connected the USB port using the Serial application.
And yes, I’ve powered the board with the battery.
This is the Serial settings page:
Schermata 2020-04-30 alle 11.41.58

Hi,
It looks like ok. Search net is fine. If you want to communicate with bg96, you can use as below:
at+set_config=cellular:(ATI)
to check the bg96 version.

Does this not response?

Send as below format:
at+set_config=cellular:(/bg96 command/)

This is the response I get except for the commands: at+version and at+scan=cellular.

When I send at+scan=cellular I get this response after some seconds:

Is it in linux?
at+scan=cellular equals as at+set_config=cellular:(AT+COPS=?)

It is MacOs.
The first send of “at+set_config=cellular:(AT+COPS=?)” returns “invalid at command”
but if I re-send the same command then the communication hang.

Hello, send AT reply "ERROR
RET_CODE: 80 "error, this error is because the AT command is sent or the format is incorrect, and the error is filtered.
Please try to send the correct AT command again. If it still fails, it may be that the configuration in the serial tool modifies the AT command and is filtered by the code.
Please try it first. My MacO system environment has some problems. The problem is fixed. I will use your serial port tool on the Mac. I’m sorry.

Hello, the serial tool you used, I tried it here, I encountered some problems and can’t use it.
I downloaded the “Serial Assistant” serial tool in the App Store, and there is no problem using the functions of RAK5010. The AT command sent as shown below, you can view the data I sent on the official website of Hologram.

Hello zhangtao,
thank you so much!