Can't get sensor data through Rak 5801 module

I have a soil sensor I am trying to use with my Rak 4631 so I connected the 5801 module to be able to use it with my device. The issue I am having is that it isn’t receiving the data back from the sensor. I have used it with an arduino and it works just fine. I did a continuity check and all the cables are good plus it turns off if any are unplugged. I have it running to 5v/gnd and a1 port. As you can see below I have my wiring and my code but it’s not responding when i dip it in the water and pull it out. What am I doing wrong?
Here is the Soil Sensor I am using. I have done this sucessfully with an adafruit wind sensor, I use the 5801 module to run power to the 12v sensor but I used the Rx1 io pin. I tried that first but I couldn’t get it to work, so then I tried the a0 port and even tried the Rak 5801 4_20 ma example but wasn’t getting any voltage so not sure what is going on considering it’s powering up

  //Void Loop Variables
  int iterations = 1; //loop iterations timer!!!
  //Amazon 32 soil sensor
  const int dry = 595; // value for dry sensor
  const int wet = 239; // value for wet sensor
void loop()
     int sensorVal = analogRead(A1);
     int percentageHumididy = map(sensorVal, wet, dry, 100, 0); 


Can you try to change analogRead(A1) to analogRead(WB_A1)?

Also, it might be helpful to check/print first the raw readings of sensorVal before mapping to percentageHumidity.

I tried both WB_A0 and WB_A1 and it’s still not working. Is there anything else I can try? the value changes when I turn the screw in the pic below but then just keeps printing the same data after. Here is the soil sensor

When you say not working, is the analog input doesn’t get any value? Can you try to feed a controlled voltage sample to WB_A1 probably coming from a power supply or battery? We have to isolate first. We can remove the soil sensor for now and test first the WB_A1.

Screen Shot 2022-02-27 at 5.53.24 AM
It prints the same value over and over. It must be working somewhat though, when I adjust the knob the values change. So something is going on with the prongs. I know it works though because I have tried it in arduino

It’s definitely giving power and it seems to recognize when I turn that resistance knob, it just doesn’t pick up the reading on the prongs

If I am in your case, I will test first WB_A1 pin if it gets the right values by having a controlled input voltage. Also will try to print raw values first before mapping to a percentage. That way, I’ll know if the issue is on the WisBlock, or with the code, or with the sensor, or with the cable, etc. Btw, your recent reply doesn’t give any meaningful info to troubleshoot properly.

I changed the value to just print the raw data it’s still doing the same thing. So when you say controlled input, I’m confused are you saying get like the prongs of the dc power supply and put it in a1?