Cellular Configuration (2)

Continuing thread from Cellular configuration + Battery Level on RAK 5010?

Hi @nero,
according to the link you provided, the problem was that the AT + QRFTESTMODE was set at 1. I changed it to 0 and now it can search the available operators. Unfortunately, there is another problem with the next step - is showing me “+CME ERROR: 13” (SIM Failure) and “ERROR: 10” (Not Inserted). I am embarrassed about this result because it can detect the network with the SIM card inserted into the slot. I tried restarting the device and setting it multiple times, but it’s giving me the same result. Oh, the power is stable by the way.

Is there a time limit that I have to put AT+COPS and other commands? if not, what could be the error?

I waited for a while and put a command again, and interestingly, it’s giving me this result below.


Hello, according to your description, the error’+ CME ERROR: 13’ and +‘CME ERROR: 10’ are reported, such as the SIM card is not available or the card slot is not recognized, and you send’at+set_config=cellular:(AT +QCSQ)’ The reply is no service, so it seems that the SIM card is not available. I don’t have your SIM card here, and I can’t find out the reason further. I also changed two or three kinds of SIM cards myself.

Hi zhangtao,
after running some experiments with the AT commands, I found out that +QSIMDET=1,0 was causing the +CME ERROR: 13, and it connects to the service properly when it was set as +QSIMDET=1,1.

I am trying to access HTTP(S) server. (https://sixfab.com/wp-content/uploads/2018/09/Quectel_EC2xEG9xEM05_HTTPS_AT_Commands_Manual_V1.0.pdf as a reference)

When I try “AT+QHTTPURL=23,80” and then type the URL, it’s giving me the error. I am guessing there should be a format to put this link properly just like we put AT commands like “at+set_config=cellular:(AT+…)” could you help me how to do that?

(When I tried “http://” it just does not work so “https://” should be used for this URL)

Sorry to keep you waiting, my colleague will give you a new version V3.0.0.11 firmware soon, you can try again. I just tested this function locally and it was OK.

Hello, you can download the new version of the firmware on our company’s official website (https://downloads.rakwireless.com/Cellular/RAK5010/Firmware/), and operate. The following is my test log:









+QHTTPGET: 0,200,19





+QHTTPPOST: 0,200,19

{ “success”: true }

Good luck

Thank you for the update, zhangtao!
I followed your example commands with the link, and it works!
Right after, I tried with my link, but it is still giving me the error although this link can be connected. Hmm… would there be a problem with my link? I will double-check it and get back to you. Again, appreciate your help!

Hello, I tried it according to your AT order. Everything is normal. You should be able to view my request data in the address you use. As shown below:

Your address should be fine, I also used the AT “at+set_config=cellular:(https://k2luc2xls2.execute-api.us-west-2.amazonaws.com/GetDeviceStatus?device_id=2)” is normal of. Please check the format again, and I will try more to see how you can reproduce your problem?

1 Like

This is very interesting… I would assume there may be some issues with the chip or the program that sends command. I use Termite 3.4 - and could you tell me which one do you use?

Hello, I am using a tool developed by our company RAK. I also tried to use the tool you used Termite 3.4, which is normal. As shown below:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.