Change the data sent by RAK5205

rak5205 send many data, i want just to send gps position and not the others data, how to do it ?
also i want to define myself the timestep to send the gps data to ttn for exemple one per 10 min

Hi @donald28.
You can send only the GPS data by modifying the firmware. To change the period of data sending , you can try “at+app_interval=time in second you want” command. For more infoRAK5205

Hi @velev, thank for your response, could you please tell me which file to modify inside the firmware ?

All send cases are in the app.c file. You can just comment the data that you don’t want. Just be aware to not touch the send procedures. :wink:

You need to modify the app.c file but the code is not documented.

What version of firmware are you using? The “at + app_interval = time in second you want” command gives me an error.

That would be version It is the latest, it is recommended to use it.

I am using version The command “at + app_interval = time in second you want” does not work. What could be the problem? I can not change the interval.

Do you get ERROR-1 ?
What is the output on the serial console ?

Yes, i get ERROR-1.

App interval is configuration parameter. You have to use it after the initialization of the board and before the join!

Thank. Now it is working

Hi! Is this still valid in the latest firmware? Because I don’t seem to be having a faster transmission interval. Just in case: I want the device to send a location packet every 30 or 60 seconds.

@lisandro can you show us the Firmware version of your device?

Sorry, that was a pretty newbie error on my side. RAK5205 Version:
In the meantime I’ve found this:


I could not find the documentation for that command, but setting it to 22 allowed me to get a position every 32 seconds.

According to Configuring your RAK7200 Using AT Commands | The Things Network

at+set_config=lora:send_interval:X:Y Set the time interval for sending data

  • X - Enable/disable the mechanism for sending data in intervals. 0: the device will not send data automatically. 1: the device will send data every Y seconds.

  • Y - Interval time in seconds. This parameter is only valid if X is set to 1.

So I don’t know why I’ve found a 2 in X.

Update: it’s not enough, ti seems it worked better in my desktop than outside. Ideally the GPS should not be turned off.

Hi Lisandro,

The trackers are design to be low power that’s why the GPS needs to be powered down.

Also, sending the coordinates every 30 seconds might violation some duty cycle or dwell time restrictions.

Hi! Yes, but the idea is to map an area for research, so power is not an issue right now.
An indeed, this might affect the duty cycle restrictions, but this should not be an issue in our case for this specific setup.

I see. Hmm. I think you have two options so you can proceed without GPS sleeping.

  1. Use an external microcontroller that will get the the data from the GPS and sensors via at+get_config=device:status command then format the data payload then send it via at+send=lora:X:YYY

  2. Modify the RAK5205 FW to setup autosending but do not activate sleep mode - Products_practice_based_on_RUI_v2.0/app_5205.c at master · RAKWireless/Products_practice_based_on_RUI_v2.0 · GitHub

1 Like