Check that my RAK2245 is actually functional

So I’ve been playing with different gateways, and found the rak2245 hat for rpi. I’ve been hitting my head for the past 6 hours trying to figure out why my gateway is sending any data to TTN. I have it connected to TTN and it shows up as online. However, when I activate a sensor to connect, I immediately get packets flowing through my other gateway, but I get nothing with the rak2245. How can I know that my RAK2245 is not defective? Are there some log files I can look at?
On a side note, I also tried the balenacloud TTN for RAK2245 and it also connected but no packet showed up

Hei @clevert ,

What firmware are you running, is it a RPI that you are running it on.
Did you properly configure the frequency plan of the Gateway?
You see nothing, not even the join requests in the gateway data tab in TTN, I assume?
Lets start here with some more info so we can diagnose.


Which TTN version?
What do the Pi logs say - does it see any info when you trigger a send?
What is your other gateway & what is that connected to?

Where can I find the logs?
TTN v2
The other gateway is a Laird RG1xx, it’s connected to the same account on TTN so I can monitor both gateways simultaneously

Google “raspberry pi logs”?

Yes it’s a rPI 4b.
Could you pass on that command to get my firmware information. I can’t seem to find that anymore

I don’t seem to be getting any traffic, not even join requests. Seems very weird. I’ve gone through the global_conf.json file and added the gateway eui and verified the frequencies. I’ve also run through the gateway-config setups.

I take it there isn’t a separate log file for the service…

I ran
tail -f /var/log/syslog

Looks like it’s not hearing my devices. Is there another config file I need to change the frequency to US915?

No, it’s in the global_conf but I’d suggest you re-run the gateway-config to ensure it’s set properly.

The US frequency isn’t known as 915 - that would more likely be AU. See Frequency Plans | The Things Network

US 915 is what TTN commonly refers to the US 902-928 frequency.
I re-selected the US freq’s in the gateway-config wizard, but no changes…
Looks like I am only receiving data from TTN

UPDATE: It heard a chirp?

Wouldn’t ever see that, wot with me being in the UK and all I see is:

Screenshot 2021-05-01 at 16.59.35


Just didn’t want you switching to AU, on account of me not knowing where in the world you are.

It is likely it heard a chirp, if the device & gateway are too close you’ll end up with CRC errors - they need to be about 5m (that’s 15 feet to you :wink:) or have a wall or some such between them.

Hah, thanks for that. I moved the node further away and also changed out the antenna on the gateway. Sadly the gateway isn’t receiving the signals. My end node is configured for CH1-8, which appears to align with what the global_conf.json file lists off for frequencies.
I think that this should be working by this point? Really makes me hope its not hardware related

Oh, I was going through the product page for the RAK2245 and guess who else likes to call this product “US915” :sweat_smile:

You say Pot-a-toe, I say read “How to Win Friends and Influence People” so be nice to the grumpy old programmer. :wink:

Do you have any other sensor devices you can try? Or another antenna (for either / both)?

Thanks for the support Nick :slight_smile:

I tried swapping the antenna on the rak module, this would make it the third antenna I’m testing on it. Still not working. On occasion I receive 1 packet, but it always "CRC_FAIL"s. This is despite pumping out a ton of messages. I will try with another node tomorrow, but seems odd that it would be the node.

On a side note, any idea what the typical temperature should be on these hats? Mine is toasty.

Normal for that generation of concentrator.

Moved the install over to a RPI3, re-reviewed the global_config file, sure enough my channels weren’t 0-7. Guess what? that fixed it. :sweat_smile:


Hurray! :partying_face:

Thanks for letting us know!

1 Like

Of course not. TTN uses the second bank of US915 channels, not the first.

Your actual problem is that your log of “success” on the TTN console shows that your node is transmitting on the wrong frequencies - it is using the first bank of channels, when it should be using the 2nd.

The gateway was right, it’s the node that’s wrong, and you seem to have gone and made the gateway wrong, too.

As long as you’re going to connect this to TTN, you need to configure everything to TTN’s frequencies. You only get to use a different sub-band in a private setup with a private server.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.