Chirpstack OTAA join error code 99


Even if I see the almost correct join message on chirpstack, the RAK serial port tool still reports that the operation failed.

Hi @haowong ,

What region do your GW and device operate? Is your APPEUI not all zero?


Here is my OTAA setting:

I haven’t tried CN470 yet but it seems that the join-accept wasn’t received by the device. Let’s check some common issues.

Have you tried joining more than once?
Is the device too near the gateway?
Is the antenna securely connected?
Are you using a RAK gateway with builtin chirpstack? Device profile properly selected?

Well, That’s what happened when I joined many times.

The distance between the device and the gateway is about 1 meter.

The antenna must be firmly connected.

The gateway is built by raspberry 4B and sx1302 modules of other brands.

Chirpstack is installed on the Alibaba cloud server I purchased.

Here is the device profile:

Are you sure the channels match? It could ne that the node is expecting the join accept on a channel which is not the one the server is sending to. Actually are there multiple join accepts, or join requests or just one set?

Sorry, I’m a rookie.

I don’t understand what you mean by channel and where to set this parameter.

@Hobo :grinning:. I changed the acceptance frequency channel of the gateway, and now the join access is successful.

But why can’t I send a message through AT command now?

The error code 1 is really confusing. It doesn’t work even if I power down the node.

I think you used the wrong at command.
at+send=lora:xx:xx, not at+send:lora:xx:xx

We have a QQ group in China, the group number is 760807281.


Everything is OK, thanks a lot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.