Configure network port to LAN and forward to "OpenVPN Network"

Hello :slight_smile:

I am running multiple RAK7249 in remote areas using cellular connection configured to use packet forwarder with Chirpstack. This is super stable and always works.
But i also want to access the Webgui on the antenna and have installed OpenVPN, this also works.

But now i want to use the network port on the antenna to connect a device to the OpenVPN network via the antenna. Can someone help me with the config to get this working?

Ive used this script for installing openVPN server GitHub

Thanks :smiley:

Hi @zjonesz,
Could you describe more about the device that you want to connect to the gateway? More specifically on how it connects to the gateway, and on which interface.
Also, the OpenVPN server is running on the gateway, correct?

Best Regards,

The OpenVPN server is not installed on the gateway, its installed on a remote server. The gateway is connected as a client.

The gateway has only 1 RJ45 network port. Normally this is configured as WAN but you can change this to LAN in the network settings.

Basically what i need is to include the network port and route all the traffic via OpenVPN

The device that is going to be connected is an ESP32 with wired ethernet.

So you want the ESP32 traffic to be transferred to the OpenVPN network, right?
Is the ESP32 assigned with IP address from the gateway’s DHCP?
Also, do you have an OpenVPN client running on the ESP?

The port and route configuration need to be done in the Network->Firewall in WisGateOS’s webui.