Connectivity Issue with New RAK5010-BG95 Boards - Unable to find a Network

Issue: Connectivity Issue with New RAK5010-BG95 Boards - Unable to find a Network

Setup: New RAK5010-BG95 Board


Hello RAK Team,

We have been using the RAK5010 with the BG96 modem for our projects for a long time, and it has performed well. However, we recently received a new batch of boards that now use the BG95-M3 modem instead of the BG96 modem used in the original version. With these new boards, we are encountering an issue where the modem fails to detect any network, continuously searching without success. Attached are screenshots of the network search command “at+set_config=cellular:(AT+COPS=?)” executed on both the original and the new boards.

Please note that the same SIM card has been used for testing both boards, and they are positioned next to each other in the same location.

Could you please advise on what might be wrong with the new boards? We have tested 5 boards, and all have same problem.

Welcome to RAK forum @MEltabakh

The BG95-M3 should be directly compatible to BG96. It has enhancement with the upgrade of BG95-M3 to NB2 but they should work fine (assuming you are using it with NB-IoT).

Few things to check:

  1. Do you have external battery connected? If none, it might be a good idea to attach once since we encounter many issues before with USB powered RAK5010. Also, if you use external battery, ensure that it can provide enough current and will not be limited by protection circuits.
  2. Is the APP RDY shows multiple times even if you do not input AT+COPS=? Will you be able to try other commands aside from AT+COPS=? Or issues occur only once you start scanning?
  3. Can you try to use at+scan=cellular?

I didn’t see it in the log files, but one difference between BG96 and BG95 is that on BG95 you have to disable GPS before it can connect to cellular. Maybe worth a try to actively disable GPS before connecting.

Thank you for your answer. Here are answers for your questions:

1- Yes, I have an external battery connected. Same setup (connections and battery let the orginal RAK5010 works fine and find networks)

2- APP RDY shows after I enter the the AT+COPS for network search. It doesn’t show if I didn’t enter the AT+COPS=? command. I tried another command for example to select a network I know it is available in my place but it doesn’t work also, it seems for me like the RF for the modem is off. I tried at+set_config=device:cellular:1 to be sure cellular is on but it doesn’t help still the modem can’t find and network.

  1. I tried to use at+scan=cellular and the modem did not give any response. But this was the case also for original BG96 modem.

I attached screenshot for the testing

Thanks for this note! Yes it seams this was the issue, once I disabled the GPS using the command at+set_config=device:gps:0, both at+scan=cellular and at+set_config=cellular:(AT+COPS=?) work fine and return the available networks.

You can check it in this screenshot

As we are using our own Zephyr OS version, I am wondering what is the corresponding AT commands for “at+set_config=device:gps:0”. Could you help me answering this question so I can implement it in our software? is it AT+QGPSEND command?

Yes, it is AT+QGPSEND