Converting rui3 rak4631 back to arduino

I am trying to restore the rak4631, which I had updated to the rui3 firmware, to get it back again to the factory arduino. I am following the Device Firmware Upgrade | RAKwireless Documentation Center and I am stuck after having executed

nrfutil.exe dfu serial -pkg -p COM31
The device opened a usb drive that shows UF2 related files.
However, in Arduino IDE I can no longer upload my application. Is there a missing step?

The device is now in bootloader UF2 mode. Normally ArduinoIDE should be able to flash an application.
The error messages in ArduinoIDE are strange? Beside of the UF2 mode, the RAk4631 should show an USB port.

Download this file
Unzip it and drag the file WisBlock_LowPower_V1.0.0_2023. to the UF2 drive, it will flash a working firmware. (148.8 KB)

Ok, I placed that file on the usb drive. It appeared to take the file and then reboot. But the arduino ide is still not programming.

Any output on the USB port?

Tried the monitor and putty, but nothing.

Are the green and blue LED doing anything after you uploaded the UF2 file?

If they are not going on and flickering for a short time, it could be the application is not started.
Reason could be that the SoftDevice was not updated when changing the bootloader.

Try to flash with the adafruit-nrfutil application from a command line

adafruit-nrfutil --verbose dfu serial --package -p <YOUR_USB_+PORT>

You can get the softdevice from the same URL where you got the bootloader ==> Download Center

Great, that was it :grinning:


I think we need to add this step (flashing the softdevice) to the documentation.
It is not the first time that the switch from RUI3 to Arduino fails.

1 Like

Hehe, I just got this thread in my email, it worked, I had another thread about this exact topic

lol my own rogue activist router box

now tests on duration/range etc.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.