Devices can't join RAK7258

Hello everyone,
I have a little problem with my RAK7258, I’m trying to excute an OTAA application, but my devices can’t join the gateway.
I tried many options as enabling the ADR, I checked also all devEUI, app_EUI, appkey of my application but it give no result. Also i installed the last firmware “Release r180”.
I use the same devices (they contain RAK811 modules) on another gateway ( RAK381) and it work perfectly .
Can anyone help me to identify the problem?


Do you use the Build in LoRaServer or TTN ? If using Build in, did you register gateway first in Gateway tab?

Todor Velev

Thank you for your reply,
I reset the gateway and I used " Build in Loraserver" , also I register a new gateway then create an OTAA application.
it give the same result as shown below

The node retry to join many time but in the end he fail.

Could you please send me this configuration page, and tell me the frequency band of your node and RAK7258, as well as the parameters of the node configuration you used(dev_eui、app_eui、app_key)

I set the RAK7258 to EU863-870 and thes nodes to EU868.
This the view of my application.

And this is the view of my device, I noitced that it doesn’t contain the activation tab as yours.

this the chosen parameters form my device

DevEui = “0059AA6EC3A75436”; // Device 1
AppEui = “d014452e71627609”;
AppKey = “171ba7193b855ef430c4a77701b052cb”;

You must ensure that your node is consistent with the three parameters on the gateway.And can you tell me what type of node you are using?