DFU Mode on 4360 with 5005


I have a 4360 on the 5005 base and I am using the arduino SDK.

Something has gone awry with my program and it is running to a degree as I see the join on the Lora server.

The issue is that I can no longer upload to it as the Arduino software can’t get the core into programming mode.

It says that I should be able to get that mode by connecting boot0 to vdd and resetting?

That doesn’t seem to work, the unit just boots up and runs the software.

How do I recover from this?


Welcome back @John_NZ

Looks like your app is blocking the Serial somehow. Happened to me as well.

Boot0 pin has no function with a RAK4631, it is for STM MCU’s.

You can force the RAK4631 into bootloader mode by double pushing the reset button after power up. You might have to try several times to get the right timing between the two pushes.

There are two indicators that you have forced the bootloader mode successfully
(1) The green LED is dimming on and off, the blue LED stays off
(2) The RAK4631 is detected as external USB drive on your computer (at least on Windows)

Hey @beegee

Thanks for the quick response.

I’ll give the double press a go tomorrow. Have retired for the night :smile:


Worked perfectly thanks.
I was adding a interrupt handling routine for a pulse input.
Initially I was disabling interrupts while sleeping, so don’t know if that was stopping the serial port as well.
Solved the issue in anycase by attaching/dettaching the interupt routine as required instead.

Thanks for your help.