Does RAK 5146 mPci-e card (USB) work with x86 Linux or just with Pi?


We have troubles of getting RAK 5146 USB variant working (or even recognized by kernel) on Industrial x86 Linux PC.

HW: OnLogic ML350g-10
OS. Ubuntu 20.04 LTS
Kernel: Tried with latest Ubuntu kernel 5.4.0-xxx and kernels 5.4.182 and 5.10.103

The RAK card does not even seem to power up (LED is off). We have tried with two cards so it does not seem to be a faulty card issue.

I have noticed most of people are using RAK cards on Pis. Is x86 PC even supposed to work? The cards are advertised as mPCI-e and:

It can be used in any embedded platform offering a free mini-PCIe slot with SPI/USB connection.

We have tried to follow RAK2247 Quick Start Guide | RAKwireless Documentation Center, but we do not know how to do this:

If you want to connect the RAK2247 mPCIe board to the Linux PC directly, make sure to have the PERST# signal (Pin 22) pulled down.

Any help is appreciated.

Yes, it should work. I have a RAK5146 USB version with a USB to MiniPCIe adapter connected to my linux AMD64 server (there is also the RAK7371 which comes in a fancy box but it’s just the same).

According the the specs of your hardware all 3 MiniPCIe sockets have USB interface but if you don’t have direct access to the PERST# signal via a GPIO, best option would be to get an external USB to MiniPCie adapter (not expensive). Or manually bring it down with a jump wire (at your own risk, I DO NOT RECOMMEND DOING THIS).

Big thanks! We have suspected that the fault is on our device.

May I still ask what does PCIe standard say? Should PCIe implementations provide direct access to the PERS# signal via GPIO or is it left for the implementer to decide?

The standard ( says " PERST# should be used to initialize the card functions once power sources stabilize.". Not sure how strong that “should” is…

In general some signals are clearly defined in the standard whilst others are completely missing (like SPI) but it’s not uncommon to miss defined signals on the interface (like I2C or PCIe). In the end the best way is to check the datasheet or schematics of the board manufacturer…

I got also the same problem but on a diferent hardware.
I’m trying to use the RAK5146 - USB on a IOT2040 from Siemens.
The hardware don’t is recognised by the operation system.

But if I use the RAK2247 - USB, it works well.
I was hopping that the RAK5146 got the same behaviour.

No it does not. RAK2247 USB worked all fine on our HW, but RAK5146 USB does not. I am not a HW guy so I could have never thought there can be so much differences in PCI-e implementations and that some vendor would rely on these “less supported” features.

I will try to make a shunt between pin22 and pin18 (gnd) to see if the concentrator turns on.

Update: After shunting the PIN22 with PIN18 the concentrator don’t turns on.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.