DR:0 unable to send 51 byte message with RAK7200


I have a RAK7200 sending to a RAK7258with the set up shown below. It works. When I change to data rate DR:0, I get network error 8 messages and the RAK7258 Packet logger shows CRC errors. I know this is due to the 51 bytes being to long to send in the permissible time. How can I set the system so that I can use DR:0?

Thank you

Auto send status: true.
Send_interval work at no sleep.
Join_mode: OTAA
DevEui: redacted
AppEui: redacted
AppKey: redacted
Class: A
Joined Network:true
IsConfirm: false
Work Mode: LoRaWAN
AdrEnable: false
EnableRepeaterSupport: false
Current Datarate: 2
Primeval Datarate: 2
ChannelsTxPower: 10
UpLinkCounter: 17615
DownLinkCounter: 0

Hello! Due to the limitation of the lorawan protocol, US915 has a maximum length of 19 bytes at Dr :0. Perhaps you can consider modifying the frequency band to AS923 or AU915’s Dr :0 to solve this problem.

That’s what I was afraid of. It looks like the GPS by itself may be 11 bytes. (51 bytes with a sky-view/ 40 bytes without) Is there a way to force the RAK to send just the GPS?

Yes, only GPS data can be sent. You can check the senser command through at+help(0-close 1-open). Moreover, RAK7200 can realize subcontracting and sending at present, and other sensors do not affect the data length.However, error will still occur because the gateway will issue MAC Command, which will occupy the data length.image

My at+help ends with the LoRaP2P AT commands. It does not show the Sensor AT commands as options, nor does the RAK respond (except with an error) to the commands enclosed in the red box. If I understand your response, turning them off will not reduce the size of the message to that allowed in DR:0. Is this correct?

Thank you,


Yes, maybe your version is not up to date. But closing them does not shorten the length of Dr:0.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.