Error 86 : The device has not joined into a LoRa network

Issue: How to fix error 86?
LoRa region: EU868


Hi, I got this error(Error 86) and I can not send any other at-commands with the RAK serial port tool application, I set the module to data transfer mode using the command at+set_config=device:uart_mode:1:1. According to the documentation, back to the AT-command mode, you need to use the “+++” command. But both this and the other commands react with error 86.
Also, using +++ without any CR or LF does not make any difference; I still get Errro86 by sending +++. Any idea how should I handle this problem?
images of rrak811 response :

Welcome to RAK forum @saeed0047 .

When switched to data transfer mode, all input to the UART will automatically be sent to the network server as uplink. You got that error because you basically trying to send an uplink while not yet joined to the network.

This will be solved by inputing +++ without any termination. Please use other Serial Terminal tools. The RAK Serial Tool will always include\r\n.

1 Like