ERROR: Failed to set SX1250_0 in STANDBY_RC mode

Issue: Error after Installation

Setup: RAK2287 | WisLink LPWAN Concentrator on RAK2287/RAK5146 Pi HAT in a Raspberry Pi 4

Server: n/a

Details:
No matter if I configure the system as described in the RAK2287 Quick Start Guide with the latest RAK2287 Firmware or if I follow the installation Guide Helium Data Only Hotspot Setup with RAK Concentrator + Raspberry Pi it will result in an Error.

snip
Feb 16 10:33:29 rak-gateway ttn-gateway[1419]: ERROR: Failed to set SX1250_0 in STANDBY_RC mode
Feb 16 10:33:29 rak-gateway ttn-gateway[1419]: ERROR: failed to setup radio 0
Feb 16 10:33:29 rak-gateway ttn-gateway[1419]: ERROR: [main] failed to start the concentrator
snip

In the manual installation I have chosen the following gateway model:

RAK7248 no LTE (RAK2287 SPI + raspberry pi)

Thanks for any information and best regards
Nicolaj

Hi Nicolaj!

I am getting the same errors. Have you found any fix for it?

I got an old RAK2287 and am facing same issue.

git clone https://github.com/Lora-net/sx1302_hal.git
cd ~/sx1302_hal
make clean all
make install
make install_conf
cd tools
../util_chip_id/chip_id 
CoreCell reset through GPIO17...
SX1261 reset through GPIO17...
CoreCell power enable through GPIO18...
CoreCell ADC reset through GPIO13...
Opening SPI communication interface
Note: chip version is 0x0C (v0.12)
ERROR: Failed to set SX1250_0 in STANDBY_RC mode
ERROR: failed to setup radio 0
ERROR: failed to start the gateway

Update: Tried setting up this rak2287 with GitHub - RAKWireless/basicstation: Basics™ Station Packet Forward protocol using Docker and it starts. However, after a couple hours it again fails with same error.

2022-11-29 15:17:20.168 [S00:INFO]  [STD]   8:    904.6MHz rf=0 freq=+300.0 datarate=8 bw=6 Explicit header
2022-11-29 15:17:20.168 [S00:INFO]  channel 9 disabled
2022-11-29 15:17:20.168 [S00:INFO] Station device: spi:/dev/spidev0.0 (PPS capture enabled)
2022-11-29 15:17:20.168 [S00:INFO] [lgw_com_open:84] Opening SPI communication interface
2022-11-29 15:17:20.168 [S00:INFO] [lgw_spi_open:88] Setting SPI speed to 8000000
2022-11-29 15:17:20.168 [S00:INFO] [lgw_connect:1192] chip version is 0x05 (v0.5)
2022-11-29 15:17:21.769 [S00:ERRO] [lgw_start:908] failed to setup radio 0
2022-11-29 15:17:21.769 [S00:ERRO] Concentrator start failed: lgw_start
2022-11-29 15:17:21.769 [S00:CRIT] Slave radio start up failed with status 0x08
ERROR: Failed to set SX1250_0 in STANDBY_RC mode
2022-11-29 15:17:21.761 [RAL:ERRO] Slave (0) - EOF
2022-11-29 15:17:21.761 [any:CRIT] Slave pid=32 idx=0: Fatal exit

ThingStack shows the gateway continuously reconnect when the docker container is restarting:


Update:

I tried changing SPI speed to 200000 and it ran for few minutes before crashing again.

Hi Rak Support team,

What are the differences between the rak2287 from the RakV2 helium miner and the DH4 in the store?


Regards
Atul.

  • For old rak2287 boards setting SX1302_RESET_PIN=25 helped.
  • For new rak2287 boards setting SX1302_RESET_PIN=18 helped.

However a documentation on what are the differences or how to detect differences would help.

I am Having this issue as well.

I purchased the PI 4 kit that comes with a RAK2287 radio and the RAK2004 Pi Hat.

The kit came with a MicroSD with an operating system installed and I have manged to get that working after sorting out a couple of internet connection issues.

However I have tried installing Raspberry Pi OS (32 Bit) and then installing the software from GitHub - RAKWireless/rak_common_for_gateway and selecting option 8 for the gateway model when installing the software. However I get the following errors and can not connect to the TTN network.

Failed to set SX1250_0 in STANDBY_RC mode;

I have tried comparing all settings between the working OS and the Non-working version but have yet to narrow it down.

The RAK2287 is a version B 915MHZ/868Mhz version
The RAK2004 Pi Hat is a version B

The Pi is a 4 Model B Rev 1.5 OS is lastest as of March 2023.

Thanks in advance Jason

Hi Anyone managed to solve this issue for the RAK 2287? I would greatly appreciate it if it is possible.

Hello,

If you have the error " ERROR: Failed to set SX1250_0 in STANDBY_RC mode" please contact us at [email protected] .

Best Regards,
Nikola

This is an old thread, but since the issue appears to be ongoing, I’m posting my own experience here for the record.

System: RAK2287 (taken from a Helium miner) on Raspberry Pi 4 Model B Rev 1.2, OS “10 (buster)”, 5.4.79-v7l+
Firmware: RAKWireless gateway RAK7248 no LTE version 4.2.7R.

My gateway appears to be working (at least, TTN sees 30-second updates). However, the “Failed to set SX1250_0 in STANDBY_RC mode” error can be fairly reliably replicated not only by power-cycling, but also by restarting the packet forwarder via the gateway-config command. Additionally, I also often receive “ERROR: wrong coding rate (0) - timestamp_counter_correction”.

My current solution is to power off the hardware for ~5 minutes and restart. Removing and replacing the Pi hat also seems to work. Thus I’m pretty convinced that this is a hardware error caused by something not resetting properly when the packet forwarder is restarted.

Hello all,

If you wish to use the RAK2287 concentrator module from a RAK Helium Miner as a regular LoRa concentrator, you will probably get some or all these errors:

rak-gateway ttn-gateway[1419]: ERROR: Failed to set SX1250_0 in STANDBY_RC mode

rak-gateway ttn-gateway[1419]: ERROR: failed to setup radio 0

rak-gateway ttn-gateway[1419]: ERROR: [main] failed to start the concentrator

To start the concentrator properly, you need to change the reset pin to PIN25. Using the rak_common_for_gateway you need to make a change in the file: /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/start.sh The line SX1301_RESET_BCM_PIN=17 should be changed to SX1301_RESET_BCM_PIN=25 and the file saved. After the change is made, start the device again. It should run as intended. If there are still problems, contact the support at [email protected]

Best Regards,
Nikola Semov

Thanks Nikola. I’ll give this a try and report back.

Nikola - this solved my problem: I can now reboot the device and/or reset the packet forwarder without error. In addition, this seems to have solved the other problem that I was struggling with: namely, that TTN recognised my gateway as ‘connected’ and received 30-second updates, but it was not detecting any traffic. The gateway finally now appears to be functioning properly. Thank you!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.