Error passing code to rak4631

Hello , so I have a Rak4631-R , and I’m trying to upload code there via arduino IDE but this error keeps happening

Can you share the complete log output from Arduino IDE.

Hello,
I can send it later but it doesnt have much more,it just has more “no ping response” and the very first line of the error says “no application image”

Connect through the terminal, send AT+BOOT and then try to upload again.

Hello again,
So I have tried that ,I’m no able to use AT commands ,I saw that you guys have the WisToolBox and it doesnt recognize the device even after i select it manually ,as I have said its a RAK-4631, can it be broken?, I have never used this one , my other one works perfectly ,so I don’t know why its not working

Also , I thought it was the bootloader , so i tried to upgrade it , but it shows that the serial port cannot be opened

Do you have access to a Jlink or a DAPLink programmer?

No , I dont have anything like that

Did you try different USB ports or a different computer?

I had a case where Windows blocked a WisBlock module (never found out why).
The solution was to

  • open Control Panel
  • go to Device Manager
  • in the View Menu, enable “Show hidden devices”
  • Open the “Universal Serial Bus controllers” list and delete manually all devices that are listed as “Unknown USB Device …”

Then I had to reboot the computer.

If all of this doesn’t help, you can contact the shop you bought the modules and ask for replacement. If you bought directly from us, you can send an email to [email protected] and ask for a replacement, if it is still in warranty.

It shows that there its conected to com5 ,it just doesnt let me work with it,
I have tried to use it on diferent computers also,and as I have said , I have another rak4630 which is working , I just tried to do the same on this one, but this one cant even connect to anything.
The thing is i dont know if I have warranty ,but this as never been used

When did you buy it?

I think that I bought it this year

Then you have warranty