Factory Reset RAK7243

I just received the RAK7243, and I configured it for LAN use. I keep getting a DNS error “temporary failure in name resolution” when I try running a ping. I don’t see the gateway show in the TTN registration as connected.

I then tried to set the WiFi settings, but I’m thinking it keeps using the LAN settings since I am getting the same error. How do I factory reset the RAK7243 OR fix the error message? Thanks.

I ended up reflashing the SD card. I then chose WiFi and everything works. I think either 1) There’s an issue with the DNS resolution with the firmware package 2) There some missing info in the tutorial to get this working for LAN configuration.

When the problem occurs, are the wifi and eth0 of the gateway working at the same time?

I was getting the problem with only LAN configuration. I did not configure WiFi. I then tried to configure WiFi while leaving LAN configuration, and I received the same error. I had to reflash the SD card and only setup WiFi.

During LAN configuration I was only requested to enter the eth0 and router IP which were both correct. I could see the device on the network with the associated IP, but I just couldn’t resolve web addresses.

I noticed in the release notes there was some DNS changes to the firmware. It’d be great to get the LAN working though. Thanks.

That’s probably the issue.

If you were manually configuring the network details rather than using DHCP, you’d have to manually configure a nameserver, too.

While if you use DHCP you’d hopefully be given one along with the IP address lease.