Fail to connect to the MQTT broker

Issue: My gateway (RAK7240) can’t connect to the MQTT broker of our server, even though I set it up with the same configuration as the other gateways that I have from another manufacturer.

Setup: RAK7240 as packet forwarder, using the protocol MQTT for ChirpStack 3.x (PROTOBUF)

LoRa® Server: ChirpStack

This is the set up in the RAK gateway:

This is the set up in on of my other gateways (IMST Lite Gateway, based on rpi):

This is the error that I get on the logs of the RAK:

Any tip or suggestion would be highly appreciated given that I have been stuck for several days now, so thanks in advance!


I wrote the MQTT Broker Address without the protocol prefix “ssl://” then I got a different error, from OpenSSL this time, stating the following:
“Tue Oct 19 10:24:12 2021 daemon.err mqttEv[8541]: [[gwBridgeS Mqtt Client]] OpenSSL Error: error:1408F10B:lib(20):func(143):reason(267)”

I found here that the error is related to wrong TLS version, so I tried v1.1 and v1.2, and the later worked.