Flashing the RAK5010 with the Espruino.hex

Issue: Flashing the RAK5010 with the Espruino.hex

Setup: Flashing the RAK5010 with the Espruino.hex for RAK5010 using the Segger IDE and the nRF52840dk as a JLink programmer

Details: Hello there
I am trying to flash the Espruino software onto a RAK5010 module via an nRF52840dk. The RAK5010 is powered via battery and is successfully flashed with the Espruino version 2v09.90 hex. The problem arises when trying to use the Espruino Interpreter via the Native IDE. The ide refuses to connect to the module.

Does anyone have any idea about some of the possible issues that could be causing us these problems.

Thanks

Welcome to RAK forum @andrew :slight_smile:

I have no experience with Espruino but I can try to check on my RAK5010. I have an nRF52840dk here so I will do the same method you did. Can you share me the link where you get the Espruino.hex? And probably a quick start guide link if there is any so I can test it.

Hi Carlrowan

I see, here is the link to the hex file: Find a binary - Espruino
And the quick start guide is based on the RAK8211 but it seems to be much the same as with the RAK5010. Here that link: Espruino on RAK8212: Getting started | Wolfgang Klenk

Thanks for the help

Did you have any luck flashing the RAK5010 unit with Espruino?

Hi @andrew ,

I will try it tonight. I’ll update you on anything I’ll find :+1:

Thanks I appreciate the help

Hi @andrew,

I tried the following FW espruino_2v09_RAK5010.hex and espruino_2v06_RAK5010.hex. I have no success on both. USB Serial is not detected and even BT is not turning on. Tried it in web IDE in Chrome also in macOS and windows 10 PCs.

Flashing back the original RAK5010 FW and my device is good as new.

Btw, I used a RAK-DAP1 to upload the hex files. I thought I have an nRF52840dk but what I have here is nRF5340dk.

Btw, it was detected by the NRF Connect in my Samsumg Note 8 as DfuTarg. Unfortunately, I don’t know what to upload next.

image

There are few guys in the Espruino that uses RAK5010. Probably it is not a bad idea to ask help from them too.

Hi @carlRowan

So you had no lucky flashing it either. Maybe it’s something to do with the method of flashing in terms of the programmer used. The documentation suggests using a J-TAG programmer or an nRF52840dk as a programmer. The software being nRF Connect or Segger studio.

I did find that I could flash the nRF52840dk itself using the espruino_2v09_RAK5010. hex and I could then program the nRF52840 using the Native Espruino IDE via BLE. Obviously the nRF52849dk doesn’t possess the BG96 module so I could test the internet functionality but I could access the input and output pins.

Anyway thanks for testing it out. I will check if any of the folks who use Espruino on the RAK5010 have any tips.

Andrew