Getting just the "driver"?

Hi all,

I need a bit of help, or maybe just explanation.

I have the RPI 4 + RAK PoE Hat + the 2243/2245 combo… I first tried the official RAK “firmware” OS thingy and that seems to works fine, the gateway is automatically discovered in the ChiprStack that come with etc…

However, my issue/question is… How to get it to work with the new ChirpStack v4 ? I tried to run it with docker on the same node (separate clean OS, DietPi ) and it works ok.

Now, the part that does not work: The gateway, how or what do I need to install to have it show in the new ChirpStack ?

I have tried to use the GitHub - RAKWireless/rak_common_for_gateway, but that seems to be doing unnecessary things, even changed the server name for some reason… I require just the part that communicate with the device and send the info to ChirpStack on UDP port (I assume its UDP packet forwarder ? this is not clear to me, since there is one already in the docker-compose from ChirpStack)… how to do that ?

Ok, figured it out. with this docker-compose:

version: '2.0'


    image: rakwireless/udp-packet-forwarder:latest
    container_name: udp-packet-forwarder
    restart: unless-stopped
    privileged: true
    network_mode: host
      MODEL: "RAK2245"
      HAS_GPS: 1
      SERVER_HOST: ""
      SERVER_PORT: 1700
      HAS_LTE: 0
      GPS_DEV: "/dev/ttyAMA0"

This nicely forward the packets to my chirpstack UDP on IP and also managed get my sensor working, so its in testing now :slightly_smiling_face: