Help required regarding RAK7258 Loriot Integration

I am using rak7258 and using it as a packet forwarder, and i want to use loriot as my network server, does anyone have a guide on how to do this?

Here is what I have tried so far.
after several tries i tried:

On the first few tries i tried:

downloads i have tried:


i have done both downloads to no avail. I am not very sure whats the difference between the 2.

I am not a gateway expert nor ever used Loriot.
But did you try our Quick Start guide for the RAK7258 for Loriot?

RAK7258 LORIOT

i have tried it but it doesn’t work, that was the main documentation i followed but to no avail

I have resetted my gateway.
redownloaded the rak7249 self extracting installer, I am using rak7258 gateway but since rak7258 is using rak7249 concentrator not sure if that affects anything.


is there anyone who has experience with loriot and gateway integration or @beegee, is there anyone that you know may be familiar with this topic?
Thank you very much for the help, really appreciate it

@Nikola @velev are the gateway experts.

@Nikola @velev (Documentation used: RAK7258 Supported LoRa Network Servers | RAKwireless Documentation Center)

Is there anything i did wrong or did i use the wrong community server for loriot to use it as the network server?
Essentially I am using rak7258 as the gateway and I want to connect it as a gateway on ap1.loriot.io
I want to use the one in singapore which there is 2. ap1.loriot.io and ap4pro.loriot.io
I followed the documentation for rak7249 and used the rak7249 for on loriot as it has come to my attention that rak7258 is using rak7249 as the concentrator therefore I assume that it should be fine since the documentation for rak7258 also uses the rak7249 device on loriot. The only difference was the i substituted eu1.loriot.io to ap1.loriot.io(since it is a free community server for singapore region).

Since i followed the documentation exactly, I am not sure what the issue is.


My rak7258 is sending in packets, but it is not registering on loriot.

Why don’t you use the right gateway type while adding the gateway at Loriot? You can choose “RAK 7258” type and follow the instructions. Works well for us.

image

I tried it too but my device is never seen
My steps are:

  1. I added the gateway mac address

  2. I added the gps not sure if that is relevant.& register the gateway:

  3. I open PUTTY to install either the self-extracting installer according to the documentation.



@AndreasK do you see any thing that i did wrongly?
the only thing i ommitted from the guide was:

i omitted:/etc/init.d/sx130x_lora_pkt_fwd disable; /etc/init.d/loriot-gw enable; reboot now
this disables the packet forwarder and enable loriot gateway did you change it to something like,
/etc/init.d/sx130x_lora_pkt_fwd disable; /etc/init.d/loriot-gw enable; reboot now

@AndreasK can i get a follow up on this problem? if there is anything i did wrong do let me know.