How to activate roaming on RAK7249

Issue: the RAK7249 is not roaming when being abroad. So we cannot connect to the internet. The SIM ist activated for roaming; we tried with an cell phone.

Setup: we set the APN on the web-interface, but there is no “activate roaming” like on many other gateways. We even didnt find any configuration setting in the ssh. The gateway is running on firmware 1.1.0063_Release r205

can anyone help please?

Dear Rudi,
Did you write these parameters correctly?

Hi @Nicholas,
we only set the APN there, no user and password needed and SIM is not locked with PIN.
All of our other gateways of other brands have a “allow roaming” in their webinterface that we have to activate; but not so the RAK7249. So we tried to send it abroad, but gateway didn’t get online.
Our provider checked the status of the SIM while the SIM was abroad, but they couldn’t see any activity.
Back to office, everything works fine as before.
Any idea?

Dear Rudi,
Our LTE module is EG95-E,Whether it is applicable to your country and ensures that your SIM card is enabled for international roaming.
image

Presumbly if the SIM really supports roaming and the modem supports the necessary frequency bands then getting it to work would involve some low level modification of the AT command sequence sent.

As a practical matter, you’ve shipped this back and forth once; perhaps it would be simplest to just plug the Ethernet into a mobile router known to work in the target country and equipped with a suitable SIM? I agree it’s inelegant, but unless you’re prepared to go there or do remote debugging at the level underlying the GUI it may be the fastest and cheapest path to getting something to work.

And if you find out you need a different modem, probably your only path.

Hi again,
we were in contact with Quectel Support and got some AT commands to check and maybe set.
How can we run the AT commands?
Thank you and best regards!
Rudolf