How to properly configure node for Pilot-Gateway-Pro-RAK7243

i’ve got my my gateway setup (I think) following the quick start guide and trying to glean more from the on line docs but they seem assume a lot.

the node is a SeeedStudio Grove - LoRa-E5 and using the AT commands i’ve set the following

  • AT+DR=US915
  • AT+KEY=NWKSKEY, “[from device settings]”
  • AT+KEY=APPKEY, “[from device settings]”
  • AT+KEY=APPSKEY, “[from device settings]”

but the device doesn’t connect , last seen stays at never and i never see any frames
I have a feeling it has to do with the enabled channels but not sure.
currently AT+CH=NUM gives me +CH: NUM, 0-71

any pointers would be helpful

Are you connecting your gateway to TTN?
TTN uses for US915 the channels 8 to 15, so you have to enable the proper channels on the Seeed LoRa-E5 node.
How that is done should be in Seeeds documentation.

do i need to connect to it? by the docs i thought i could set up an independent network?

You can, in which case you’d need to register the node with whatever on-gateway or cloud based network server you were using.

In the official LoRaWAN spec, nodes in multi-subband regions like the US are required to try to join on random selections across all possible subbands, because officially they can’t “know” which subband the network is going to be on. This is rather inefficient, since only a minority of the packets would be picked up, so often people cheat the spec and preconfigure the node to the subband on which their gateways are listening.

My guess would be that even if you’re not connecting it to TTN, your gateway is still configured for the second subband, channels 8-15, though for a private network you could chose to set it to a different one, and might want to if there were already a lot of local usage of the default.

Also make sure the public / private network switch which controls the syncword is set the same way for both the gateway and the node. Most are set to use the public syncword, even if they’re private, but the setting absolutely has to match.

thanks for the quick response, this is my first stab at this so still trying to understand it.

The ChirpStack Gateway OS looks to me to provide a complete lorawan stack, There is this doc on direct connection. but things might be a little lost in the translation.

your gateway is still configured for the second subband, channels 8-15
yup i can see that in the chirpstack network server config


I’ll get the node configured to be the same and keep my fingers crossed.

again, thanks for the help, so far :smiley:

AT+CH=NUM, 8-15

+JOIN: Start
+JOIN: Network joined
+JOIN: NetID 000000 DevAddr 00:22:81:EC
+JOIN: Done

so first step down, many miles to go.