Impossible to set gateway id

Hello everybody

I have set a rak2245 on a raspberry in order to have a ttn gateway.
It works nice except for one point :
I have change the gateway_id in the json in order to have a nice identification.
I have double checked that the json was effectively changed.

Even with this change when I go on the ttn website to watch the data flow, I see that they all come from the gateway with an identification like “0000000000fffe”.

What happens ?
how could I correct this problem ?

Thank you

1 Like

Hi @dynamitron,

Which json are you editing exactly?


i am talking about the one that you can edit when you choose the option " edit packet_forwarder". this json is called “gobal_conf.json”

Hi @dynamitron,

Can you please post the global_conf.json cofig you have.
One mroe question. The Gateeway EUI in the first post you say you are getting the data from has should be 16 symbols, yours is 14. Is this a typo, or…
Can you show some packet logs from TTN too, please.

Thank you


I found this morning the following point :slight_smile:
I initialy set up the gateway with an eternet connection and there everything is ok.
As I want to install the gateway in a box very close to my outdoor antenna, I switched to wifi for connection to ttn.
With wifi it gives this identification with a lot of zero.
Any help ?


You can see the gateway_id with a lot of 0

“time”: “2019-07-15T17:46:43.548082996Z”,
“frequency”: 868.1,
“modulation”: “LORA”,
“data_rate”: “SF7BW125”,
“coding_rate”: “4/5”,
“gateways”: [
“gtw_id”: “eui-000000000000fffe”,
“timestamp”: 41818187,
“time”: “2019-07-15T17:46:44.525546Z”,
“channel”: 0,
“rssi”: -18,
“snr”: 8.5,
“rf_chain”: 1,
“latitude”: 50.xxxx,
“longitude”: 4.xxxx,
“altitude”: 140

Hi @dynamitron,

Don’t care about the global_conf.json file.
You can open the file named “local_conf.json” in the folder </opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/>, and then you can see some information like this:

Yes, this is the gateway ID, and it will be generated based on the MAC address of Pi automatically. If you find it is incorrect, you can delete this file and restart the gateway to generate a new local_conf.json file.

I deleted the json and now the gateway is not forwarding anything anymore.
I do not think your suggestion is valid.

after a gateway restart with gateway-config, the global_conf.json is back and gateway works but still with a gtw_id with a lot of 0.

Check the mac address of eth0, and the mac address of wlan0, If both mac addresses are oK, Try modifying the file /lib/systemd/system/ttn-gateway.service and rebooting to see if the issue still exists.

I’m having the exact same problem. setup is an RAK 831, a RPi Zero Shield for RAK831 LoraWAN Concentrator v1.4, and a RPi 0W. Is on Buster with latest packages and the RAK common installer from github. Installer finishes w/o errors as far as I can tell. However the local_conf.json refuses to post a valid GWID even with the edits suggested above. I can manually edit the local_conf file but on restart of the packet forwarder it reverts. Also it refuses to show a connection to TTN even though it is configured to use TTN and I’ve double checked everything in the setup on that end. Any help would be appreciated.


Rename the and files in the directory /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd, and then modify the gateway_id in the local_conf.json file.

Tried that and still nothing. I’m getting an error now when I run tail on syslog that says: rak-gateway ttn-gateway[6028]: ERROR: [main] failed to start the concentrator. I wasn’t getting that before. The problem with local/global conf files resetting is gone though so I guess thats a step in the right direction.

What is the gateway_id you filled in local_conf.json?

I took the wlan0 interfaces MAC address and added fffe in the middle.

The files and are used to reset the gateway_id in local_conf.json after the gateway is restarted.

On rpi zero, can the gateway not connect to ttn?

I tried renaming both scripts. That caused errors in startup procedure. Then I replaced instances of eth0 with wlan0 in both files and renamed the files back to their original names. The startup errors went away but it fails to start the concentrator and fails startup. I can resolve dns to the ttn load balancer address. It appears to be an issue with starting the concentrator on a pi0w.

Are you using this source code

Do you enable the spi interface?

Thanks, in the three or so nuke and paves I’ve done trying to make it work I must have forgotten to enable spi that last time. It’s working for the gateway side now. Still not showing online in the TTN backend though. Double checked that gateway was set to use TTN and that it could resolve the address. Gateway has correct EUI/GWID and TTN has matching entries.

Can you send me a copy of the global_conf.json and local_conf.json files?

On my side, the porblem is not solved. I still need a solution.
Any help ?