Include path issue under VS Code tutorial example

Everyone, please excuse my scattergun line of questioning. I can’t find an existing topic thread to post into. Bascially, I’m trying to explore the different options for using the RUI3 environment.

I went carefully through the VS Code setup tutorial. All my “application stuff” lives on my F: drive rather than C: so there is a bit of having to redirect things on installation, and this tends to have a knock on problem with paths that are automatically configured sometimes being wrong. I found and fixed the arduino_path but I suspect that there is an issue with the include path too.

Following through with the Arduino_Led_Breathing example, I end up with Intellisense squiggles under uint8_t that should come from <stdint.h>. I also am missing as the Arduino things like Serial, pinMode and analogWrite.


Which path should I fix? Is this an Arduino thing or a VS code thing? Where are the headers I should normally be hooking up to?

Hi @psupine

I am guessing it is a Arduino Extension problem or Arduino CLI/IDE.

Not sure where to add or change, but did you check the Arduino Extension configuration:

Yes, that’s where I edited the arduino path and the command path.



The error looks more like Intellisense configuration doesn’t find the BSP packages. But no idea how to setup that part. I have my BSP’s in the default path and then set the project path to my custom path (on D:) That works.


Where do the BSPs normally end up? I can’t find them!

(Incidently, I removed Arduino 2.0.2 and have put 1.8.3 back)

I only installed the nrf58 package, not the STM one, because I’m only using the RAK4631, but I can’t imagine that being important.

In the Windows user folders, for me that is in


OK … I have the same path to Arduino15\packages, and way below that I found the include files.


I’ll keep poking around on VS Code settings. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.