Incorrect Channel Plan

Hi, my RAK4200 LoRa node is joining my network server, but when my server sets the channel plan in my node with a downlink message after joining, the channel plan in my node (viewed with at+get_config=lora:channel) is incorrect.

The channels that my Chirpstack network server is using is US915 channels 31-39. I start with all 72 channels enabled in my RAK4200 node. After successfully joining, channels 31-39 are properly enabled and all other channels are disabled except channels 0,8,15, and 23. These channels remain enabled but should be disabled.

I am using the RAK4200 with firmware version RUI v3.2.0.12.

Has anyone else ran into this problem?


Hi @lancepitka,

You can use the following AT command to enable or disable any channel manually:

About the problem you met, we’ll test with ChirpStack too.

I did the same operation, everything is normal! There are no redundant channels that are turned on. You try to see if there is anything wrong with your profile.

Thanks for your replies Nicholas and Fomi! I will keep trying to see if I can get mine to work too. I will also try updating the firmware on my RAK4200 to see if that helps.