Issue OTAA Join


I’m using a RAK 7258 gateway and several sensors from RAK and Dragino.
After updating the firmware I’m unable to add new sensors (Dragino LHT65, in this case) to the application. They have a common issue: the OTAA Join fails.

I put the old firmware back, but then the application section couln’t be opened anymore (got an html error saying that certain files couldn’t be accessed.).

To sum it up, I did a fresh install with the latest firmware, started from scratch, made new applications and ran into the same issue as in the beginning, no OTAA Join.

When I look into the logfile I see:

__nsParseJoinReq: join_req mic check failed

The APPeui and APPSkey are correctly set in the Dragino, and the DEVeui is set in the application.

One particular thing which I can notice, but I have no means to compare it with other sensors, is that if I look at the join request, I see:

"JoinRequest": {
        "AppEUI": "DC F1 66 7F 6A 4C 7F 77 ",
        "DevEUI": "A4 40 21 05 01 31 ED 67 ",
        "DevNonce": "BA52"

Note that there’s a space behind the 77 in the AppEUI ánd after 67 in the DevEUI, I can imagine this being an issue, but no idea how to change it. In the Dragino sensor I don’t have any options concerning this.
The AppEUI and DevEUI are correct valuewise.

Application details:
Device auth mode: unified app key (tried both options)
Auto add LoRa device: on

If anyone can point me out in the right direction…would be appreciated!

Hello everybody,

Problem is solved and besides the migration issue concerning the firmware and apps (error message), it was entirely the user’s fault. (ashamed here).

After re-entering the keys in the sensor (a hundred times) I noticed the AT command. I used APPSKEY instead of APPKEY. Sigh. :slight_smile:

Thanks all!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.