LB801 setup at+version works, all other commands error

Hi,

Just received an LB801, and although it seems to connect fine to to the RAK Serial port tool and I can get messages when pressing a button such as

Key1: Press: key 1
Not Joined
No OTAA parameters

However only the at+version command works:

>> at+version
OK2..00.2.1.1

All other commands return ERROR-1 or ERROR-2

>> at+get_config=device:status
ERROR-2

I’ve tried with both the RAK Serial Port tool on Windows and CuteCom on Linux - same result.

Long press on a key gives:

23:59:11:855] Key1 long Reset...␍␊
[23:59:13:768] Welcome to RAK811.␍␊
[23:59:13:768] Version: 2.00.2.1.2␍␊
[23:59:13:776] Selected LoraWAN 1.0.2 Region: AU915␍␊
[23:59:13:832] Current Mode<0xa3><0xba>LoRaWAN.␍␊
[23:59:13:832] Initialization OK!␍␊
[23:59:13:832] ␍␊
[23:59:13:840] No OTAA parameters␍␊

What do I need to do to get it to accept the other commands so I can configure it ?

A bit more of an update: I found this guide to the RAK881 AT commands
RAK 881 AT Commands V1.4 which seems a bit more helpful that any of the other docs. A few commands from there also work, sich as:

at+band
OK.EU868
at+get_config=dev_eui
<deveui>

Note that none of these are in quite the same format as documented elsewhere, and don’t require “lora” to be included.

BUT: - I still can;t work out how to set the app_key, which I need to be able to configure the device to join using OTAA

To anyone else that finds themselves in a similar position this manual seems to be the set of commands that work:

https://www.hellasdigital.gr/index.php?dispatch=attachments.getfile&attachment_id=745

Even so I have so far only manages to get to to run in ABP mode - in OTAA it just comes up with “No OTAA Parameters” even though I think I’ve set them all.