Missing at.c file during compilation

When trying to compile RAK5205 and RAK7204 code straight from RAK github template code get an error message as shown below. Also this compiler setup is proving very painful to use. I have spent two days just trying to add a simple print statement to the template code! I thought there were a lot of steps required to just compile some code and upload it (ie when compared to Keil or STM32CubeIDE), but that was nothing compared to when things going wrong (which is becoming quite common). After a successful few attempts at loading code, I just started getting ‘No Serial Port’ and timeout errors with the RAK LoRaButton Upgrade Tool. I searched google, and tried hitting the reset button, and tried lots of different tools, and different boards. Finally managed to get things working again when reloaded the boot loader and could reload the firmware again. So after fixed that issue then immediately have hit this problem with the missing “At.c” file, which I assume is something with the backend as it provides this error with standard RAK code. While the API approach may simplify the process of adding customisations, the number of steps involved in the compilation process combined with the number of things going wrong is an issue.

nordic/Makefile_nRF:526: Cannot find source file: …/…/RUI/Source/nordic/app/at.c

mkdir _build

cd _build && mkdir nrf52_xxaa

Compiling file: system_nrf52.c

Assembling file: gcc_startup_nrf52.S

Compiling file: nrf_log_frontend.c

Compiling file: nrf_log_backend_rtt.c

Compiling file: nrf_log_backend_uart.c

Compiling file: nrf_log_backend_serial.c

Compiling file: nrf_log_str_formatter.c

Compiling file: nrf_log_default_backends.c

Compiling file: nrf_memobj.c

Compiling file: pm_mutex.c

Copying file 50.00%

Copying file 60.00%

Compiling file: ble_dfu.c

Compiling file: ble_dfu_unbonded.c

Compiling file: nrf_dfu_svci.c

Compiling file: nrf_pwr_mgmt.c

Compiling file: rui_inner_main.c

Compiling file: nrfx_uart.c

Copying file 70.00%

Compiling file: nrfx_uarte.c

Copying file 80.00%

Compiling file: nrfx_clock.c

…/…/RUI/Source/nordic/rui_inner_main.c:81:10: fatal error: at.h: No such file or directory

#include “at.h”


compilation terminated.

…/…/components/toolchain/gcc/Makefile.common:272: recipe for target ‘_build/nrf52_xxaa/rui_inner_main.c.o’ failed

make: *** [_build/nrf52_xxaa/rui_inner_main.c.o] Error 1

make: *** Waiting for unfinished jobs…

Copying file 90.00%

Copying file 100.00%

RAK5205 and RAK7204 should select “RAK811-H”/“RAK811-L” as following picture


duoh! thanks. My dumb mistake! Taking too many shortcuts trying to get back on track.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.