Multiple WisLink LX200V30 EVB over one power line?

The product page for the WisLink LX200V30 EVB says that up to 8 modules can interface with each other. Can anyone give me information on how this can be achieved?

Do you need pairs at each end of the power line? Or can one EVB at one end of the power line have two separate connections at the other end?

How would the modules be set up for this?

Hi @jrveale,
It is possible to set up more modules, but they will work as one of them will be master and all the others will be slaves. The slaves won’t be able to communicate with each other.

You have to notice 2 facts:

  1. More slaves with the master, narrower the data bandwidth;
  2. If you connect that many devices and you have a long cable you are going to have more issues like disconnecting, reconnecting, stuttering, etc.

Based on these facts I could say that we don’t suggest you use the maximum number of devices. To set up the master and the slaves you can use this tool

Hi Nikola,

Thanks for the help.

I’m having some trouble with the tool you provided a link for, is there any documentation for the tool that might help me?

For starters, when I try installing the tool (by either “Setup.exe” or “SetupAvitar.msi”) it wants .NET Framework v1.0.0 to be installed to run, which I’m not convinced is available anywhere (the oldest on the MS website is v3.5 SP1)

Hi @jrveale,
As far as I understood you have a problem with instaling the tool? When you download the SetupAvitar folder you will see this in the folder:
Now you have to install the last item before the installation of the Avitar, so you install WinPcap_4_1_2 and then you can run the “Setup”.

Hi Nikola,

I’ve installed WinPcap_4_1_2, but when I run “Setup” I get the below:


I currently have .NET Framework 4.8 (latest).

What is your operating system? I’ve just tested it on Windows 10 and it’s working without any problem.

I also have Windows 10. (Enterprise, if that matters).

Hi @jrveale,
I doubt that the problem is in the AVitar itself. Maybe some software on your pc makes the problem. I don’t know if this will work but you can try to delete all the frameworks and to install the latest one.

Hi Nikola,

Sorry to reopen an old thread, but I recently came back to this and am having the same issue.

I’ve even tried running SetupAvitar on a new Virtual Machine (running Windows 10 Home 64 bit) and still get the same issue. I’ve tried downloading the latest .NET Framework runtime and devtools, but still get the dialog about “setup requires the .NET Framework version 1.0.0”

Any suggestions?

Hello @jrveale,
Go to “Turn Windows features on or off” :

And enable “.NET Framework 3.5 (includes .NET 2.0 and 3.0)”, then try again:

Thanks, this helped. For posterity: the 4.1.3 WinPcap didn’t work for me, I had to uninstall and use 4.1.2 to get SetupAvitar.msi to run

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.