My board doesn't respond when I run at+get_config=device:status



Details:Hi! I’ve got the Sim on, the antennas connected and the battery. All connected. But when I run the command at+get_config=device:status it gets blocked and doesn’t respond to me. Thank you very much for the information

Do you know your firmware version number?
Have you tried other at commands to respond? For example "at+version".

If you test indoor, gps will cost 6s to try to get data. Before it responses, do not send any other at. If you test outdoor, it will response soon.

Hey, Nero, thanks for your help. Actually the command doesn’t work because the problem is that it can’t read the GPS position, neither indoors nor outdoors, so the pallet is blocked.

Can you post your log? What about other at, like at+set_config=cellular:(AT+COPS=?) to search net? I am not clear it does not response anything or response with not correct data?

The thing is, when I run at+get_config=device:statusThe thing is that when I run at+get_config=device:status it gets blocked and doesn’t respond to anything, and I’ve checked that’s when it accesses to read GPS, because if I remove that part it does return the value read from the other sensors.
On the other hand, if I execute the command at+set_config=cellular:(AT+COPS=?) it returns the following:

+COPS: (2, “Movistar”, “Movistar”, “21407”,0),(3, “Orange SP”, “ESPRT”, “21403”,8),(3, “Orange SP”, “ESPRT”, “21403”,0),(3, “vodafone ES”, “voda ES”, “21401”,0),(0,1,2,3,4),(0,1,2)

And if I do at+set_config=cellular:(AT+COPS?) :
+COPS: 0,0, “Movistar”,0

OK. If you test indoor, gps will get data at most 6s because of signal. Try outdoor and connect antenna.
As fr the net, It looks like you want to use GSM? And the net status is ok. I am not clear what problem you meet?

The problem is that when you proceed to read the gps data the device is blocked. And I’ve tried asking for both indoor and outdoor data.

Because the gps is also from bg96. Before it back, other at will block. Can you get gps outdoor with at+get_config=device:status? Or it is also not working?

No, it is also not working outdoors.

Do you connect the GPS antenna?