[Need help] No response for AT commands suddenly

Hello, we have a RAK7431 which worked fine with RAK gateway 7244 previously.
We could use AT command to setup RS485 sesonr and upload sensor data to Chirpstock periodically as well as we could send downlink test message to RAK7431.

However, today we just tried to connect RAK7431 to another sensor device, we just found no response for AT commands suddenly. Even if RAK7431 only connect with power and usb cable for computer, there is no response for AT comands such as “at”, “at+version”, …

We have tried to press the reset key, but the terminal only shows a message “RUI Bootloader Version: 3.2.4”. Would someone help on how to recovery function of RAK7431?
Thanks a lot!

Hello @chiching,
I belive this problem occurs because the device is in boot mode.
The command to get the device in boot mode is at+boot. This is the response of the device when it is in boot mode :

In order to get out of boot mode run the command at+run and you will be able to use the normal at commands :

Best Regards

Hi @Nikola ,
Thanks for your great help! The device is back to normal mode and works fine again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.