Need help to Upload firmware in RAK3127 using Arduino ide, and also not respond AT command


  • This example shows led breathing by analog.


#if defined(WISBLOCK_BASE_5005) || defined(WISBLOCK_BASE_5005_O)

uint8_t ledPin1 = LED_GREEN;

uint8_t ledPin2 = LED_BLUE;


#warning please set the right pin refer to the documentation.

uint8_t ledPin1 = 0xFF;

uint8_t ledPin2 = 0xFF;


int val = 0; // variable for LED brightness value

bool state = false; // variable for control led brightness status

bool ledSwitch = false; // variable for switch led

void valChage()


state = !state;   // invert led control brightness status

if (val == 0)

    ledSwitch = !ledSwitch; // switch led when one of the led is darkest


void setup()


//initialize serial communcation at 115200 bits per second



Serial.println("RAKwireless Arduino LED Breathing Example");


// initialize the LED pin as an output

pinMode(ledPin1, OUTPUT);

pinMode(ledPin2, OUTPUT);


void loop()


// call function when led is brightest or darkest

if (val == 0 || val == 255)


// determine to make the led lighter or darker

if (state)




// To switch the lighting led

if (ledSwitch)

    analogWrite(ledPin1, val);  // Light the green led


    analogWrite(ledPin2, val);  // Light the blue led


how can I wake up RAK3127 pls help me out.

I have encountered a similar situation.
And there are many reasons for this error.
Most of them have the same problem that the RAK3172 has one or more pins that are communicating over 3.3V (maybe 4.2V or 5V…). So it’s broken.

In a document that I came across, I don’t remember which one it was.
It mentions Tx2, and Rx2 can communicate with the outside via standard 5V.
But when I connected to CH340E with Vcc 5V I got an error can’t detect baud like the picture you provided.

Try the following steps before we get started with the more complicated stuff.
-Remove unnecessary connections to Tx2, Rx2.
-Check the connection of Tx2, Rx2. Make sure there is no open circuit.
-Power supply voltage at 3.3V
-Restart your laptop/PC
-Check Com port

  • Connecting to the same laptop/PC power outlet with interfering devices can also affect it. It is possible that an outdated adapter or an active inductive load is causing interference on the AC power system power line.

Thank you for reply me
No I’m giving only 3.3v.

I’m verify the CH340E is working fine … And I’m also Check on Device manager its detect com port

Also I CH340E verify with other controller its working fine.

-After Restart my pc but still not working now.
-Com port is detected.
-Tx2, Rx2 connection is right.
-Power supply voltage at 3.3V is also correct.

pls help me out to wake RAK3127.

Did you cross the RX/TX lines?

RXD of CH340 goes to UART2_TX
TXD of CH340 goes to UART2_RX

It would be helpful if you could share your schematics.

If you have my problem I think you can re-upload the code running the command AT+BOOT through serial just after the device is power up and before it goes dead.

The other solution of course would be to erase and upload a the latest .hex firmware with the ST-Link but you would need that tool first.

Anyway from what I can see when you don’t start the Serial or simply have somethings that gets stuck in the firmware you won’t be able to communicate with the RAK3172.

Tank you for reply me …
I’m followed this circuit diagram but still not working RAK3127

Thank you for reply me …
can you pls guide me to erase and upload .hex file
can you pls provide me .hex file and also connection diagram of ST-Link and RAK3172.

pls help me out

Here the doc for upgrading the firmware: RAK3172 Module Quick Start Guide | RAKwireless Documentation Center
Here the guide for ST-LINK: STM32CubeProgrammer Guide for RAK Modules | RAKwireless Documentation Center

Thank you for suggestion me

I flow the procedure which you provide to me but still its not working now…

pls help me out to solve this issue …

i have same problem.

did you solve problem?