New RAK5205 having issues sending data

I’m developing a LoRaWAN network for my institution. Deployed a Lorix One gateway and packet forwarding to TTN… confirmed online.

Got a RAK5205 tracker board with firmware version Could not get it to successfully connect to network with OTAA mode, but got it to send a few messages to TTN in ABP mode. But now no messages are going thru. Status indicates ‘JoinedNetwork:true’ and getting ‘Unconfirm data send OK’ messages in the board’s serial port tool, but no data are showing up on my TTN application (status last seen was 13 days ago).

I’ve verified that device address, network session key, and app session key all match between board and device I set up on TTN.

Device is sitting about 3 ft away from my gateway in my office. Been spinning my wheels on this for a day now and need outside help. Thanks!

Can be described in more detail, your node uses the channel and gateway model, and in TTN configuration, screenshots node configuration interface.

What do you mean by ‘node uses the channel and gateway model?’ In the node configuration I haven’t seen anything relating to pointing the node at the gateway. So for all i know the node will connect to any gateway signal. Are there specific "at+ " commands to give to the node that points it to my gateway?

Since, I’m new I can only upload one image per post.

Can you take a picture of the node and gateway? In this way, I can see more clearly and solve your problem.

Here you go. Tried to get them both in one picture because of this forum’s limits. The Lorix one is PoE powered & networked to our LAN. Its up and visible on TTN. The node is connected to my laptop for power/testing. The GPS antenna is passed through a port to the outside so I can try to get a signal.

Hi @jadelaars Please flash the newest firmware for RAK5205
Then try again and give feedback.

I tried that last week without success. The LoraButton Upgrade tool was only looking for .bin files and 7zip cannot open the .rar file. Do you have any suggestions?

After downloading the. rar file, decompressing will see the. bin file appear.
Check the channel used by entering at command through the node. (at+get_config=lora:channel)Since the gateway you are using is not RAK’s product, it is better to confirm that the gateway is consistent with the channel used by the node.

I was able to upgrade the firmware. Both the node and the gateway are configured to US915. On the node I have channels 8-15 (902.3 to 903.9) turned on. The gateway is broadcasting on the same sub-band. Still no communication. I have the node sending out info (GPS, temp, etc…) every 5 minutes. According to the gateway logs, it is not receiving any packets. I am also troubleshooting this same issue with the gateway supplier.