New Sensor Hub issues

Hello, I have the sensor hub with the temperature and humidity sensor modules, I already configured them with the wisToolBox app, but they do not report with the time that I configure them.
For example, if I set a reporting time of 70sec, the hub sensor reports between 2-10min.

Welcome to the forum @Donaciano

Can you send a screenshot of WisToolBox with the settings page for the sensor?


```Yes, here is the setup


Hi, good morning.
Also i tried to do join with the “join button” in the app, however it didn’t work. I have been test in 5 sensor hub

Hello Donaciano,

I do not see any picture in your post, only links. Can you retry to send them please.

With ““join button” in the app” you mean the “Join Network” button?
If the device is already connected to a LoRaWAN server it will start a new Join Request sequence and on successful join you will get a small popup message:

If you want to send only periodically and not on events, make sure in the sensor settings you have only Send periodic uplink selected and none of the other options:

hi beegee.

I have this setup in the sensors but, in the platform (TTS) it doesn´t report in the configured time

In this image you can see the report of the sensor hub and its time stamp

Hi Donaciano,

Your settings for the Sensor Hub send interval looks good, I will try to confirm the 65 seconds interval on my device, it is a little bit unusual value.

What LoRaWAN region are you using?

I see that the Sensor Hub is sending each sensor value as a separate message. Does this change if you reset the Sensor Hub (AT command ATZ)?

When I did setup my Sensor Hub, I had a similar behaviour that all sensor values were sent in individual packets, once I reset the device, the data was sent in a combined packet.
I am not sure whether that could be a reason for the strange send intervals you are seeing.

Hi beegee.

i am using the US915 band and have not tried to reset the sensor hub with the AT command. I’ll try it and tell you if it works. I also have problems joing the sensor hub with the lora network. I’m using the comand AT+JOIN=1:1:8:1, but appears a notification with the message “+EVENT:JOIN_FAIL”, however in TTS console i see a JOIN acepted message.

For the connection problem, is your gateway connected over ethernet, wifi or cellular connection?
The failed join could be because of a latency problem in the communication between TTS and the gateway.

Try AT+JOIN=1:1:8:10, the last parameters is the number of retries to join. It might still fail one or two times (I see that all the time on all my LoRa devices), but it will retry 10 times to connect and it should succeed.

hello begee, I had some problems with the update of the wistoolbox app, the main problem is that the sensor prube configurator does not appear.

It also won’t let me update the sensor hub.

And I would like to have information on the ATC commands.

thank you.

I am having the same issues with the new WisToolBox version.

Forwarded everything to the R&D team.
Please wait for their feedback.
New AT commands are not documented yet (even I don’t know what they do) and they need the new firmware version of the SensorHub V1.6.5

Can you get the current SensorHub firmware version with ATC+HUB_INFO=? and tell me.


The problem with the missing sensor tab in WisToolBox is fixed, please retry.
For the firmware update, it is still failing for me, I am waiting for the R&D team to fix it.


Regarding the firmware update, I got it to work with the help of our R&D team. Seems there is a cache problem with the app, it holds an invalid version of the new firmware instead of downloading the latest good one.
Please follow these steps:

  • Uninstall WisToolBox from the phone
  • Reboot your phone
  • Install WisToolBox again and login to your RAK ID
  • Connect to the SensorHub
  • Goto Firmware in the app, then select RAK2560
  • Click on the RAK2560 firmware with version 1.1.65 and upload it to the SensorHub

Please let me know if that worked for you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.