No GPS data on /dev/ttyAMA0

Issue: No data from GPS doing a cat /dev/ttyAMA0, no time reference in packet forwarder

Setup: I have a RAK2287 bundle, with the shield with a GPS on it (it is a MAX-7Q instead of advertised ZOE-M8Q GPS chip). I use the software I received on the microSD with the bundle.

Server: configured with TTN following the tutorial, but currently it won’t mark gateway as connected… even if the packet forwarder sends data and doesn’t give any error. => I fixed it by removing the temp variable from being sent in the JSON to TTN, as this is not an allowed variable and leads to rejection of the STAT info. Now it is good, except the GPS…

Could you help me fix this issue please?

Best regards.

TTN console has an issue with showing connected gateways:

If you send data from a device and the data arrives at the other end, that’s the best test - other suggestions I’ve made are in the thread of the post

Thanks for the answer on this point Nick. As I said in the edited post, in my situation that was caused by a “temp” variable in the STAT packets sent to TTN, that was not accepted by TTN. I fixed it the packet forwarder, recompiled it, and that now works properly. But that’s useful to know, as I already experienced something similar as what you describe with my other gateway.

Still, no data from the GPS on my gateway, that part of the problem remains.

Hi Nicolas,

Can you make sure that the GPS reading position is normal.

There is a possibility that the location may prevent GPS from being found.

Hi Nicholas, I put it in a place where my neo-6M based other GPS is working properly, with the same antenna. However, even if I had no coverage, I should have data flowing from GPS don’t you think?

Is that also expected that GPS chip is a max-7Q for an European customer, when a ZOE-M8Q is advertised everywhere from the webshop to the docs?

Is it outside?

Are you sure you can receive it?

Yes, and yes I am… :confused:

Still that doesn’t explain the different GPS chip (that doesn’t support Galileo, which is a shame for an European customer…)

Doesn’t matter anymore, we built all the satellites, we are taking them back at the end of the year :wink:

I also have RAK2287, I found the Zoe-M8Q is actually on the rear of the minipcie card, its antenna connector is also on the minipcie card, adjacent to the lora rf connector. This Zoe-M8Q provides the 1pps sync for the SX1302 and its serial output is on ttyAMA0. Once it has a lock, you can see a 1pps flash from blue LED under the RF shield.
The other GPS module on the adaptor HAT is not connected to 1pps of the SX1302.

Maybe you could check that SPI and I2C are both enabled from raspi-config.

Already done, already good… :confused:

Blue LED is fixed on the RF shield for me

https://photos.app.goo.gl/Yi4YDRFpYRrAnFtn7

i added these tags to my config file.

“gps”: true,
“fake_gps”: false,

I finally got a RMA, new board is working properly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.