P2p on rak5205 error 80

Issue:Cannot send data between two nodes in P2P mode- ERROR 80

Setup:2 RAK5205 boards which contains RAK811 modules.
firmware 3.0.0.14beta

Server:P2P

Details:Hello everybody. I don’t want to connect to the TTN or anything on the internet but just to establish connection between tow boards in P2P.
After configuring the boards according to the “Quick start guide” the P2P chapter, I’ve been trying to send data but all I get is ERROR 80 on the transmitter side without receiving something on the receiver board.
In addition I want to mention that in both of them (receiver and transmitter) I see that transfer mode is 1 (when I’m doing the at+get_config=lora:status) which is weird to me because I except to see different values for receiver and transmitter - but maybe it is not the problem.
thanks for all

Hi @potato,
This is error 80’s meaning image
This happens when you execute at command and then execute another one too fast and the device is busy.

Hi @Nikola thank you,
I also find it on internet but it doesn’t make any sense because I see this message right after I send the first time. and even if wait long time it is steel happening . I couldn’t find a way to overcome this ERROR.

Hi Nikola thanks for answering me, but this error popped up any time I’m sending something even if I wait a long time.
It seems like the devices can’t get out of this situation.
What else can I do?

‫בתאריך יום ג׳, 12 בינו׳ 2021 ב-17:03 מאת ‪Nikola Semov via RAKwireless Forum‬‏ <‪[email protected]‬‏>:‬

another question: do you have an idea how long I should wait?
I waited for 10 min and steel the same Error occured .

‫בתאריך יום ד׳, 13 בינו׳ 2021 ב-9:32 מאת ‪potato potato‬‏ <‪[email protected]‬‏>:‬

Hi @potato,
I’m sorry for the late reply. I just tested RAK5205 in p2p mode and it worked fine without any problem. Which version of the firmware do you use? Try to upgrade the FW according to this guide.
The latest version of the FW you can find here.

my firmware is 3.0.0.14LBETA.
I’ve been trying to upgrade it many time and it doesn’t work.
here is what the Upgrade Tool writes to me right after I choose the new firmware file and press START:
-“open serial port”
-if I press restart button it writes to me “Enter Boot mode success” and stack here
-if I don’t press it, it writes to me " Time out Error please click stop to restart operation"
-after I press STOP “STOP! please choose the serial port again”
I really don’t know what else to do please help me!! @Nikola
thank you
potato

Hi @potato,
Try with this firmware.

Hi @Nikola
unfortunately this firmware does the same thing like before!
there is another way to update the firmware ?
if not what else I should do ?
Potato

Can you give me the response of “at+get_config=lora:status”.