Packet forwarder configuration

Hello,
Apologies if this is not the right place for this enquirey, please redirect me if so.
I’ve just set up a TTN lora gateway using a RAK2247 and a Rasperry Pi booted from RAK’s bootable SD image. It works but I’m getting HUGE volumes of log data to /var/log/daemon.log. Is there any way to control the verbosity of logging?
Much of the logging is to do with the wireless AP which I have disabled by blacklisting the wifi driver - I’m running over ethernet and want to conserve power - is there a way of configuring the software to not implement the wifi AP?
Thanks.

Use the command "sudo gateway-config",
1.

2.Select 2 Enable Client Mode, this will turn off ap mode.
2019-11-05%2009%3A08%3A53

Thank you, I should have spotted that. Could you also help me understand whats going on with these log lines:

Nov 5 09:25:53 rak-gateway loraserver[571]: time=“2019-11-05T09:25:53Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:53 rak-gateway lora-app-server[572]: time=“2019-11-05T09:25:53Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:54 rak-gateway lora-gateway-bridge[569]: time=“2019-11-05T09:25:54Z” level=error msg=“integration/mqtt: connection error” error=“Network Error : dial tcp 127.0.0.1:1883: connect: connection refused”
Nov 5 09:25:55 rak-gateway loraserver[571]: time=“2019-11-05T09:25:55Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:55 rak-gateway lora-app-server[572]: time=“2019-11-05T09:25:55Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:56 rak-gateway lora-gateway-bridge[569]: time=“2019-11-05T09:25:56Z” level=error msg=“integration/mqtt: connection error” error=“Network Error : dial tcp 127.0.0.1:1883: connect: connection refused”
Nov 5 09:25:57 rak-gateway loraserver[571]: time=“2019-11-05T09:25:57Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:57 rak-gateway lora-app-server[572]: time=“2019-11-05T09:25:57Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:58 rak-gateway lora-gateway-bridge[569]: time=“2019-11-05T09:25:58Z” level=error msg=“integration/mqtt: connection error” error=“Network Error : dial tcp 127.0.0.1:1883: connect: connection refused”
Nov 5 09:25:59 rak-gateway loraserver[571]: time=“2019-11-05T09:25:59Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:25:59 rak-gateway lora-app-server[572]: time=“2019-11-05T09:25:59Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:26:00 rak-gateway lora-gateway-bridge[569]: time=“2019-11-05T09:26:00Z” level=error msg=“integration/mqtt: connection error” error=“Network Error : dial tcp 127.0.0.1:1883: connect: connection refused”
Nov 5 09:26:01 rak-gateway loraserver[571]: time=“2019-11-05T09:26:01Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:26:01 rak-gateway lora-app-server[572]: time=“2019-11-05T09:26:01Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:26:02 rak-gateway lora-gateway-bridge[569]: time=“2019-11-05T09:26:02Z” level=error msg=“integration/mqtt: connection error” error=“Network Error : dial tcp 127.0.0.1:1883: connect: connection refused”
Nov 5 09:26:03 rak-gateway loraserver[571]: time=“2019-11-05T09:26:03Z” level=error msg=“gateway/mqtt: connecting to mqtt broker failed, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”
Nov 5 09:26:03 rak-gateway lora-app-server[572]: time=“2019-11-05T09:26:03Z” level=error msg=“integration/mqtt: connecting to broker error, will retry in 2s: Network Error : dial tcp [::1]:1883: connect: connection refused”

Which appear continuously.
Thanks again.

OK, So I tried killing the lora-app-server, lora-gateway-bridge and loraserver tasks and my ttn feed still works fine, so I guess I only need the lora-pkt-fwd service. So how do I configure the system so it doesn’t launch the unwanted services?
Thanks again.

This are the commands to disable all ChirpStack (former LoRaSever) process:
sudo systemctl disable loraserver
sudo systemctl disable lora-app-server
sudo systemctl disable lora-gateway-bridge
sudo systemctl disable postgresql
sudo systemctl disable mosquitto
sudo systemctl disable redis

Regards,
Todor

1 Like

Thank you, perfect, will do.