Phantom interrupts

Hi everyone, I’m using a WisBlock base, lpwan core and the interface extension board. I’m building a weather station and have temp/humidity, wind speed/direction working (Davis weather station). I have the rainfall working also, but testing on the desk over a period of 24hrs or so, I’m getting phantom interrupts (pin #define rainPin WB_IO1). Any ideas as to why this would be happening? Is it possible to try something else?
Thanks in advance…here’s a screenshot of the serial.print…

Hello Andy,

Just my experience with some sensors, they can be sensitive to the RF waves of a LoRaWAN transmission if the sensor is close to the antenna.
Personally I experienced false alarms (IRQ’s) of a radar sensor that was mounted a few centimeter away from the LoRa antenna. The only way to solve it was to disable the radars IRQ output while a LoRaWAN packet was transmitted.

Strange enough, I had the same problem as well with a PIR sensor, which shouldn’t be sensitive to RF waves.

Yeah ok, thanks @beegee, I’ll set it all up in enclosure and test in the field. Hopefully it’ll be ok. I can’t turn off the interrupt while the LoRaWan packet is transmitted, as it’s possible to miss rainfall under that scenario.

You could as well try to put a low pass filter on the IRQ signal.

Thanks @beegee, I’ll do that also.

Hi Andy,

regarding switching off the sensor during sending a LoRaWAN message, sending a packet take ~ 6 seconds including the RX windows. I think you would not loose too much rain detection during this time.