Powering Wisblock from battery wont boot

So everything works fine connected to the USB

then I disconnect and plug in the battery connector in the correct polarity and it wont boot?

why is that?

have you tried pressing the reset buttong?

have tried that but is not a good solution if you have this inside an enclosure, i cant be pressing reset button everytime i want to turn it on.

is there any other way>?

This is an issue we have been “fighting” … the reset button can be extended, so if there is an option for putting a momentary switch on your enclosure, you just need to connect it to GND and RST on the RAK4631.

However, the unit is supposed to boot up without pressing the reset button.

We have one program that this does not work with, and I am currently tidying up the code and have somehow overcome this problem … which leads me to believe that there was some errant code somewhere which caused the “issue”, though I am no closer to determining what that errant code was.

The problem for us is that the enclosed unit will be in a remote location and even if we provide a rest button, we won’t have anyone there to press it.

yea is kind of annoying not knowing if it is going to boot. and tell the technician to double click fast to boot and check if the led is ON !!!

double click is not to boot the board, that is to set it into programming mode

lol thats how i have been able to make it boot lol

Hi all, we had this problem with the very first bootloader version, but since April this year it is fixed with a new bootloader.

Can you check what bootloader version is on your RAK4631 modules. It should be March 31st 2021. If it is older you need to update the bootloader.

Instructions how to check the bootloader version and how to update the bootloader can be found here: Updated bootloader for RAK4631


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.