Problem RAK5860

I have connected an ESP32 (RAK11200) ,an BG77 module (RAK5860) with both antennas and the battery to a RAK19001 board. The stable voltages I have are as follows:
3V3_S: 3.3V
3V3: 3.3V
VBat: 4.2V
VDD: 3.3V

The blue LED on the 5860 board flashes every 4 seconds (off), while the green LED flashes every 4 seconds (on).
The AT commands respond erratically.
Using the example ‘@file RAK5860_GNSS_Satellite.ino’, the ATI command responds without any problem:

Revision: BG77LAR02A04

But if I try to enable the GPS using AT+QGPS=1



I get the same response with several commands to configure MQTT or TCP.
Any ideas?

Hi @Jorgela ,

By the looks of it, it seems to be a supply issue. What battery do you use? Does it have a protection circuit that could limit that current it can source?

Hi Carl,

No, I use two 18650 batteries connected to the board. I even tried using an external laboratory power supply with the same result. The current oscillates between 90 and 170 mA when using the RAK5860_Unvarnished_Transmission.ino sketch without entering any AT command.

Hi Carl,

Could you suggest any solution for this problem? Is the hardware broken? Do you have the diagram of the RAK5860? (I don’t find it at the documentation Rak site)

I am experiencing what seems to be the same issue. I have the same setup (RAK11200 + RAK5860 on a RAK5005-O base board). I connected one 18650 battery as well as USB. The BG77 is constantly rebooting.

Anything I can do to fix this?