RAK 10701-P-field-tester no distance

Hi, I’ve got the rak 10701-P hooked up to a rak gateway and I’m using TTN. I tried to setup a webhook by following a RAK guide and using this server : https://dev.disk91.com/fieldtester/ttn/v3. I’m getting the RSSI and SNR but the min and max distance on the device is stuck at 250m. I think it’s related to the decoder used in the server since at some point there was a issue with the calculating of the distance and maybe this server hasn’t been updated.
If I try with datacake, I can’t get any dowlink so no RSSI, SNR or distance. I’m able to visualise the data from the device and plot a map but I can’t make the downlink work.

I suspect that I have to put this parameter in TTN but I have no idea where.

This is what I ticked in TTN for the datacake webhook

How many gateways can see the Field Tester?

Distance is in 250m steps, so if there is only one gateway and it is in the range between 0 and 250m, the display is correct.
Even if there are multiple gateways, if they are all within 250m distance, you get the same info.

Yes, there is only one but in datacake I can’t see that :

How can I make it work with datacake ?

I’m gonna try with the dev.disk91 to go outside for some distance.

Is your data arriving in Datacake?

Okay, I tried outside and yes it’s “working”. I got a distance of 500m on the tester when I was at 584m from the gateway and it got back to 250m at 392m.


And yes I’m getting data in datacake :

I’m also facing a problem with receiving downlink messages from The Things Network (TTN). While my gateway appears to be connected to the network and transmitting data successfully, downlink messages from TTN simply aren’t making their way to my devices. I’ve checked the configuration settings, verified the gateway’s EUI, and even tried adjusting the frequency plan, but to no avail.